summaryrefslogtreecommitdiff
path: root/endless/Makefile.am
diff options
context:
space:
mode:
authorP. F. Chimento <philip.chimento@gmail.com>2013-04-18 13:05:51 +0200
committerP. F. Chimento <philip.chimento@gmail.com>2013-04-24 17:36:34 +0200
commitc6abea86f4bf5b18b2ea4026968ddc2da2c9134c (patch)
treea917c4a436eeed8e5100bf469cc8c9a9b5ada088 /endless/Makefile.am
parent1521b0b3283c6ffa2e83aa993eaf7dfcfb28be55 (diff)
Define G_LOG_DOMAIN
Improvement to the build system: this allows you to turn on debug messages from the SDK by running G_MESSAGES_DEBUG=EndlessSDK ./myprogram Use G_MESSAGES_DEBUG=all to turn on messages from other libraries too.
Diffstat (limited to 'endless/Makefile.am')
-rw-r--r--endless/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/endless/Makefile.am b/endless/Makefile.am
index cb5a259..b8d1a59 100644
--- a/endless/Makefile.am
+++ b/endless/Makefile.am
@@ -22,8 +22,12 @@ libendless_@EOS_SDK_API_VERSION@_la_SOURCES = \
$(endless_public_installed_headers) \
$(endless_private_installed_headers) \
$(endless_library_sources)
+# Defining G_LOG_DOMAIN allows you to run any program with
+# G_MESSAGES_DEBUG=EndlessSDK ./myprogram
+# and turn on debug messages
libendless_@EOS_SDK_API_VERSION@_la_CPPFLAGS = \
@EOS_SDK_CFLAGS@ \
+ -DG_LOG_DOMAIN=\"EndlessSDK\" \
-DCOMPILING_EOS_SDK
libendless_@EOS_SDK_API_VERSION@_la_CFLAGS = $(AM_CFLAGS)
libendless_@EOS_SDK_API_VERSION@_la_LIBADD = @EOS_SDK_LIBS@