summaryrefslogtreecommitdiff
path: root/endless/Makefile.am
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2013-09-04 14:27:17 +0100
committerEmmanuele Bassi <ebassi@gnome.org>2013-09-12 12:35:04 +0100
commitd36338c48c350024694af457b76e9c01b4f66a73 (patch)
treec5a009208f7d437335531f00cc23ef1bd1741d9e /endless/Makefile.am
parentf419efd50898862a63c9f31a61115c5b6de79fec (diff)
Add EosFlexyGrid
A layout manager for flexible grid layouts using the same algorithm of the Discovery Center. The UI pattern is going to be used in the app store and other native applications, so it makes sense to have this widget in the SDK.
Diffstat (limited to 'endless/Makefile.am')
-rw-r--r--endless/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/endless/Makefile.am b/endless/Makefile.am
index 1a7f56f..2ad59bf 100644
--- a/endless/Makefile.am
+++ b/endless/Makefile.am
@@ -34,7 +34,8 @@ endless_private_installed_headers = \
endless/eossplashpagemanager.h \
endless/eostypes.h \
endless/eoswindow.h \
- endless/eosactionmenu-private.h
+ endless/eosactionmenu-private.h \
+ endless/eosflexygrid.h
endless_library_sources = \
endless/eosapplication.c \
@@ -47,7 +48,8 @@ endless_library_sources = \
endless/eostopbar.c endless/eostopbar-private.h \
endless/eosactionbutton.c \
endless/eosactionmenu.c \
- endless/eoswindow.c
+ endless/eoswindow.c \
+ endless/eosflexygrid.c endless/eosflexygridcell.c endless/eosflexygrid-private.h
# Endless GUI library
lib_LTLIBRARIES = libendless-@EOS_SDK_API_VERSION@.la