summaryrefslogtreecommitdiff
path: root/test/Makefile.am.inc
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2017-02-27 18:23:21 +0000
committerEmmanuele Bassi <ebassi@gnome.org>2017-03-06 15:46:57 +0000
commit6a98d05520f40411ffa95865cfd3d91926f36d2c (patch)
treef6881e1abd76a65518471dc2209d19513aea19f1 /test/Makefile.am.inc
parent24c8971b0b52c10b78b1345dc6a59a82d2698cd3 (diff)
Disable Metrics support when running tests
We currently use a private DBus session using dbusmock to intercept all calls to the EOS Metrics DBus API, and avoid sending bogus metrics when distchecking or running the test suite. The Metrics API now looks for an environment variable and short circuits if found, which means we don't need these contortions any more. This also allows us to drop the dbusmock Python module dependency. https://phabricator.endlessm.com/T15748
Diffstat (limited to 'test/Makefile.am.inc')
-rw-r--r--test/Makefile.am.inc11
1 files changed, 4 insertions, 7 deletions
diff --git a/test/Makefile.am.inc b/test/Makefile.am.inc
index ecde40a..0d74647 100644
--- a/test/Makefile.am.inc
+++ b/test/Makefile.am.inc
@@ -83,19 +83,15 @@ AM_JS_LOG_FLAGS = \
@JASMINE_REPORT_ARGUMENT@ \
--no-config \
$(NULL)
-LOG_COMPILER = $(top_srcdir)/test/gtester-mock-event-recorder.sh
-AM_LOG_FLAGS = -k --verbose
+LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) $(top_srcdir)/tap-driver.sh
+LOG_COMPILER = $(top_srcdir)/test/tap-test.sh
EXTRA_DIST += \
+ test/tap-test.sh
test/run-with-dbus \
test/test-bus.conf \
$(NULL)
CLEANFILES += stderr.log
-dist_noinst_SCRIPTS = \
- test/gtester-mock-event-recorder.sh \
- test/wait-for-service-helper.py \
- $(NULL)
-
if ENABLE_WEBHELPER
AM_JS_LOG_FLAGS += --include-path=$(top_srcdir)/webhelper
endif ENABLE_WEBHELPER
@@ -105,6 +101,7 @@ endif ENABLE_WEBHELPER
# Set XDG_CONFIG_HOME so as to avoid cluttering the user's actual config
# directory with junk from the tests
TESTS_ENVIRONMENT = \
+ export EOS_DISABLE_METRICS=1; \
export GI_TYPELIB_PATH="$(top_builddir)$${GI_TYPELIB_PATH:+:$$GI_TYPELIB_PATH}"; \
export LD_LIBRARY_PATH="$(top_builddir)/.libs$${LD_LIBRARY_PATH:+:$$LD_LIBRARY_PATH}"; \
export XDG_CONFIG_HOME=`mktemp -d $${TMPDIR:-/tmp}/sdktestconfig.XXXXXXXX`; \