summaryrefslogtreecommitdiff
path: root/test/Makefile.am.inc
diff options
context:
space:
mode:
authorPhilip Chimento <philip@endlessm.com>2015-04-17 13:23:51 -0700
committerPhilip Chimento <philip@endlessm.com>2015-04-17 13:23:51 -0700
commita7ec9a08a19c80ed48aacabff8fa330d70800574 (patch)
tree300f267621f22d920219cc1d07907965dbfd0d80 /test/Makefile.am.inc
parent912da5ca8c4e5689a10fad256b1bf634516c3180 (diff)
Don't define dist_noinst_DATA in included Makefile
This is vulnerable to being overwritten. Instead, define it in the top level Makefile and append to it in the included Makefile. [endlessm/eos-sdk#3054]
Diffstat (limited to 'test/Makefile.am.inc')
-rw-r--r--test/Makefile.am.inc2
1 files changed, 1 insertions, 1 deletions
diff --git a/test/Makefile.am.inc b/test/Makefile.am.inc
index d070b95..dc90227 100644
--- a/test/Makefile.am.inc
+++ b/test/Makefile.am.inc
@@ -34,7 +34,7 @@ credits_resource_files = \
$(NULL)
test/smoke-tests/images/credits.gresource: test/smoke-tests/images/credits.gresource.xml $(credits_resource_files)
$(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir)/test/smoke-tests/images $<
-dist_noinst_DATA = test/smoke-tests/images/credits.gresource
+dist_noinst_DATA += test/smoke-tests/images/credits.gresource
CLEANFILES += test/smoke-tests/images/credits.gresource
EXTRA_DIST += \
test/smoke-tests/images/credits.gresource.xml \