summaryrefslogtreecommitdiff
path: root/test/Makefile.am.inc
diff options
context:
space:
mode:
authorPhilip Chimento <philip@endlessm.com>2017-04-12 15:24:48 -0700
committerPhilip Chimento <philip@endlessm.com>2017-04-12 16:14:06 -0700
commite54bec3feb08b09de64945f72885c8c37258de60 (patch)
treee86d9c5ff13eaf6b7b5498d68624a413a18b544d /test/Makefile.am.inc
parent72694e1790f779edc8f8ac163a66af561bf14500 (diff)
build: Remove Webhelper
Webhelper is now in its own repository: https://github.com/endlessm/webhelper https://phabricator.endlessm.com/T16203
Diffstat (limited to 'test/Makefile.am.inc')
-rw-r--r--test/Makefile.am.inc18
1 files changed, 1 insertions, 17 deletions
diff --git a/test/Makefile.am.inc b/test/Makefile.am.inc
index 0d74647..98ec69e 100644
--- a/test/Makefile.am.inc
+++ b/test/Makefile.am.inc
@@ -56,17 +56,6 @@ EXTRA_DIST += \
test/utils.js \
$(NULL)
-if ENABLE_WEBHELPER
-javascript_tests += \
- test/webhelper/testLocal.js \
- test/webhelper/testTranslate.js \
- test/webhelper/testTranslate2.js \
- test/webhelper/testWebActions.js \
- test/webhelper/testWebActions2.js \
- test/webhelper/testUpdateFontSize.js \
- $(NULL)
-endif ENABLE_WEBHELPER
-
# Run tests when running 'make check'
TESTS = \
test/endless/run-tests \
@@ -86,16 +75,12 @@ AM_JS_LOG_FLAGS = \
LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) $(top_srcdir)/tap-driver.sh
LOG_COMPILER = $(top_srcdir)/test/tap-test.sh
EXTRA_DIST += \
- test/tap-test.sh
+ test/tap-test.sh \
test/run-with-dbus \
test/test-bus.conf \
$(NULL)
CLEANFILES += stderr.log
-if ENABLE_WEBHELPER
-AM_JS_LOG_FLAGS += --include-path=$(top_srcdir)/webhelper
-endif ENABLE_WEBHELPER
-
# Use locally built versions of Endless-0.gir and libraries; this may need to be
# changed to AM_TESTS_ENVIRONMENT in a future version of Automake
# Set XDG_CONFIG_HOME so as to avoid cluttering the user's actual config
@@ -105,7 +90,6 @@ TESTS_ENVIRONMENT = \
export GI_TYPELIB_PATH="$(top_builddir)$${GI_TYPELIB_PATH:+:$$GI_TYPELIB_PATH}"; \
export LD_LIBRARY_PATH="$(top_builddir)/.libs$${LD_LIBRARY_PATH:+:$$LD_LIBRARY_PATH}"; \
export XDG_CONFIG_HOME=`mktemp -d $${TMPDIR:-/tmp}/sdktestconfig.XXXXXXXX`; \
- export WEBHELPER_UNINSTALLED_EXTENSION_DIR="$(top_builddir)/.libs"; \
export TOP_SRCDIR="$(abs_top_srcdir)"; \
export BUILDDIR="."; \
$(NULL)