summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorPhilip Chimento <philip@endlessm.com>2013-10-02 15:00:41 -0700
committerPhilip Chimento <philip@endlessm.com>2013-10-02 15:00:41 -0700
commitc34c856b07061e23fa22b364f64be50d9121b867 (patch)
treeb0ab5888751e7dc1c23f6f5dc4e0d77c6e0dea8d /test/Makefile.am
parente17e7600545cfdfa5da41a3dba6cb31292e77e96 (diff)
Put local typelib and lib directories in test environment
When running the tests, we want them to pick up the local copies of Endless-0.typelib and libendless-0.so instead of the installed copies. The tests now also run properly when there are no installed copies. [endlessm/eos-sdk#321]
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 4730b8b..60a4057 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -50,3 +50,10 @@ AM_JS_LOG_FLAGS = \
$(NULL)
LOG_COMPILER = gtester
AM_LOG_FLAGS = -k --verbose
+
+# Use locally built versions of Endless-0.gir and libraries; this may need to be
+# changed to AM_TESTS_ENVIRONMENT in a future version of Automake
+TESTS_ENVIRONMENT = \
+ export GI_TYPELIB_PATH="$(top_builddir)$${GI_TYPELIB_PATH:+:$$GI_TYPELIB_PATH}"; \
+ export LD_LIBRARY_PATH="$(top_builddir)/.libs$${LD_LIBRARY_PATH:+:$$LD_LIBRARY_PATH}"; \
+ $(NULL)