summaryrefslogtreecommitdiff
path: root/test
diff options
context:
space:
mode:
authorPhilip Chimento <philip@endlessm.com>2015-09-01 19:42:10 -0700
committerPhilip Chimento <philip@endlessm.com>2015-09-01 19:42:10 -0700
commitfd1247c9a62fb545f07ed4ad44b57e5519e4036f (patch)
tree0c5087024d90feb7a3c88208d20b096f13870e3a /test
parentf3d049026879d456f353017387a1331d42fe5263 (diff)
Add some ordering to tests
There are tests that test the same DBus name, so we don't want them to run at the same time. [endlessm/eos-sdk#3566]
Diffstat (limited to 'test')
-rw-r--r--test/Makefile.am.inc6
1 files changed, 6 insertions, 0 deletions
diff --git a/test/Makefile.am.inc b/test/Makefile.am.inc
index 2fca7ea..1071c9f 100644
--- a/test/Makefile.am.inc
+++ b/test/Makefile.am.inc
@@ -87,6 +87,12 @@ EXTRA_DIST += \
$(NULL)
CLEANFILES += stderr.log
+# Order some tests so that they don't try to export the same DBus names
+test/webhelper/testTranslate2Old.log: test/webhelper/testTranslate2.log
+test/webhelper/testWebActions2.log: test/webhelper/testTranslate2Old.log
+test/webhelper/testWebActions2Old.log: test/webhelper/testWebActions2.log
+test/webhelper/testLocal.log: test/webhelper/testWebActions2Old.log
+
# Use locally built versions of Endless-0.gir and libraries; this may need to be
# changed to AM_TESTS_ENVIRONMENT in a future version of Automake
# Set XDG_CONFIG_HOME so as to avoid cluttering the user's actual config