summaryrefslogtreecommitdiff
path: root/test
diff options
context:
space:
mode:
authorSam Spilsbury <smspillaz@gmail.com>2013-12-14 11:09:12 -0800
committerPhilip Chimento <philip@endlessm.com>2014-01-15 18:24:45 -0200
commit0fcd808fc138d3f0cb7e0bdb40fbee1ae86aae43 (patch)
treef2a852e8f3c54c73e29f3567c25d46df78809678 /test
parent7844fc96bbf1d446923fc4e6cd1b3981104e6b0a (diff)
Clean up the structure of the tests directory
Move all the tests for the SDK into tests/endless, move all the demos into tests/demos, move all the smoke tests into smoke-tests [endlessm/eos-sdk#444]
Diffstat (limited to 'test')
-rw-r--r--test/Makefile.am.inc (renamed from test/Makefile.am)38
-rw-r--r--test/demos/Makefile.am.inc5
-rw-r--r--test/demos/flexy-grid.c (renamed from test/flexy-grid.c)0
-rw-r--r--test/endless/Makefile.am.inc17
-rw-r--r--test/endless/run-tests.c (renamed from test/run-tests.c)0
-rw-r--r--test/endless/run-tests.h (renamed from test/run-tests.h)0
-rw-r--r--test/endless/test-action-button.c (renamed from test/test-action-button.c)0
-rw-r--r--test/endless/test-action-menu.c (renamed from test/test-action-menu.c)0
-rw-r--r--test/endless/test-application.c (renamed from test/test-application.c)0
-rw-r--r--test/endless/test-flexy-grid.c (renamed from test/test-flexy-grid.c)0
-rw-r--r--test/endless/test-hello.c (renamed from test/test-hello.c)0
-rw-r--r--test/endless/test-init.c (renamed from test/test-init.c)0
-rw-r--r--test/endless/test-page-manager.c (renamed from test/test-page-manager.c)0
-rw-r--r--test/endless/test-splash-page-manager.c (renamed from test/test-splash-page-manager.c)0
-rw-r--r--test/endless/test-window.c (renamed from test/test-window.c)0
-rw-r--r--test/smoke-tests/Makefile.am.inc5
16 files changed, 37 insertions, 28 deletions
diff --git a/test/Makefile.am b/test/Makefile.am.inc
index e5fef17..826824f 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am.inc
@@ -1,39 +1,21 @@
# Copyright 2013 Endless Mobile, Inc.
-noinst_PROGRAMS = \
- test/run-tests \
- test/flexy-grid \
- test/smoke-tests/hello
-
TEST_FLAGS = @EOS_SDK_CFLAGS@ -I$(top_srcdir) -DCOMPILING_EOS_SDK
TEST_LIBS = @EOS_SDK_LIBS@ $(top_builddir)/libendless-@EOS_SDK_API_VERSION@.la
+ENDLESS_TESTS_DIRECTORY = $(top_srcdir)/test
-test_run_tests_SOURCES = \
- test/run-tests.c test/run-tests.h \
- test/test-init.c \
- test/test-hello.c \
- test/test-application.c \
- test/test-page-manager.c \
- test/test-splash-page-manager.c \
- test/test-window.c \
- test/test-action-menu.c \
- test/test-action-button.c \
- test/test-flexy-grid.c \
- $(NULL)
-test_run_tests_CPPFLAGS = $(TEST_FLAGS)
-test_run_tests_LDADD = $(TEST_LIBS)
-
-test_smoke_tests_hello_SOURCES = test/smoke-tests/hello.c
-test_smoke_tests_hello_CPPFLAGS = $(TEST_FLAGS)
-test_smoke_tests_hello_LDADD = $(TEST_LIBS)
+noinst_PROGRAMS = \
+ test/endless/run-tests \
+ test/smoke-tests/hello \
+ test/demos/flexy-grid
-test_flexy_grid_SOURCES = test/flexy-grid.c
-test_flexy_grid_CPPFLAGS = $(TEST_FLAGS)
-test_flexy_grid_LDADD = $(TEST_LIBS)
+include test/endless/Makefile.am.inc
+include test/demos/Makefile.am.inc
+include test/smoke-tests/Makefile.am.inc
javascript_tests = \
test/tools/eos-run-test/sanitycheck.js \
- test/tools/eos-application-manifest/testInit.js \
+ test/tools/eos-application-manifest/testInit.js \
test/webhelper/testTranslate.js \
test/webhelper/testWebActions.js \
test/wikipedia/models/testCategoryModel.js \
@@ -44,7 +26,7 @@ EXTRA_DIST += $(javascript_tests)
# Run tests when running 'make check'
TESTS = \
- test/run-tests \
+ test/endless/run-tests \
$(javascript_tests) \
$(NULL)
TEST_EXTENSIONS = .js
diff --git a/test/demos/Makefile.am.inc b/test/demos/Makefile.am.inc
new file mode 100644
index 0000000..797cfd3
--- /dev/null
+++ b/test/demos/Makefile.am.inc
@@ -0,0 +1,5 @@
+# Copyright 2013 Endless Mobile, Inc.
+
+test_demos_flexy_grid_SOURCES = $(ENDLESS_TESTS_DIRECTORY)/demos/flexy-grid.c
+test_demos_flexy_grid_CPPFLAGS = $(TEST_FLAGS)
+test_demos_flexy_grid_LDADD = $(TEST_LIBS)
diff --git a/test/flexy-grid.c b/test/demos/flexy-grid.c
index 2008af4..2008af4 100644
--- a/test/flexy-grid.c
+++ b/test/demos/flexy-grid.c
diff --git a/test/endless/Makefile.am.inc b/test/endless/Makefile.am.inc
new file mode 100644
index 0000000..2835934
--- /dev/null
+++ b/test/endless/Makefile.am.inc
@@ -0,0 +1,17 @@
+# Copyright 2013 Endless Mobile, Inc.
+
+test_endless_run_tests_SOURCES = \
+ $(ENDLESS_TESTS_DIRECTORY)/endless/run-tests.c \
+ $(ENDLESS_TESTS_DIRECTORY)/endless/run-tests.h \
+ $(ENDLESS_TESTS_DIRECTORY)/endless/test-init.c \
+ $(ENDLESS_TESTS_DIRECTORY)/endless/test-hello.c \
+ $(ENDLESS_TESTS_DIRECTORY)/endless/test-application.c \
+ $(ENDLESS_TESTS_DIRECTORY)/endless/test-page-manager.c \
+ $(ENDLESS_TESTS_DIRECTORY)/endless/test-splash-page-manager.c \
+ $(ENDLESS_TESTS_DIRECTORY)/endless/test-window.c \
+ $(ENDLESS_TESTS_DIRECTORY)/endless/test-action-menu.c \
+ $(ENDLESS_TESTS_DIRECTORY)/endless/test-action-button.c \
+ $(ENDLESS_TESTS_DIRECTORY)/endless/test-flexy-grid.c \
+ $(NULL)
+test_endless_run_tests_CPPFLAGS = $(TEST_FLAGS)
+test_endless_run_tests_LDADD = $(TEST_LIBS)
diff --git a/test/run-tests.c b/test/endless/run-tests.c
index db9c289..db9c289 100644
--- a/test/run-tests.c
+++ b/test/endless/run-tests.c
diff --git a/test/run-tests.h b/test/endless/run-tests.h
index 8947a5a..8947a5a 100644
--- a/test/run-tests.h
+++ b/test/endless/run-tests.h
diff --git a/test/test-action-button.c b/test/endless/test-action-button.c
index 7e4ad15..7e4ad15 100644
--- a/test/test-action-button.c
+++ b/test/endless/test-action-button.c
diff --git a/test/test-action-menu.c b/test/endless/test-action-menu.c
index 0450f6c..0450f6c 100644
--- a/test/test-action-menu.c
+++ b/test/endless/test-action-menu.c
diff --git a/test/test-application.c b/test/endless/test-application.c
index 75165d4..75165d4 100644
--- a/test/test-application.c
+++ b/test/endless/test-application.c
diff --git a/test/test-flexy-grid.c b/test/endless/test-flexy-grid.c
index 0c6c3cc..0c6c3cc 100644
--- a/test/test-flexy-grid.c
+++ b/test/endless/test-flexy-grid.c
diff --git a/test/test-hello.c b/test/endless/test-hello.c
index 687f14d..687f14d 100644
--- a/test/test-hello.c
+++ b/test/endless/test-hello.c
diff --git a/test/test-init.c b/test/endless/test-init.c
index 482c079..482c079 100644
--- a/test/test-init.c
+++ b/test/endless/test-init.c
diff --git a/test/test-page-manager.c b/test/endless/test-page-manager.c
index a39fb3f..a39fb3f 100644
--- a/test/test-page-manager.c
+++ b/test/endless/test-page-manager.c
diff --git a/test/test-splash-page-manager.c b/test/endless/test-splash-page-manager.c
index 06105aa..06105aa 100644
--- a/test/test-splash-page-manager.c
+++ b/test/endless/test-splash-page-manager.c
diff --git a/test/test-window.c b/test/endless/test-window.c
index 32639be..32639be 100644
--- a/test/test-window.c
+++ b/test/endless/test-window.c
diff --git a/test/smoke-tests/Makefile.am.inc b/test/smoke-tests/Makefile.am.inc
new file mode 100644
index 0000000..2c0fba3
--- /dev/null
+++ b/test/smoke-tests/Makefile.am.inc
@@ -0,0 +1,5 @@
+# Copyright 2013 Endless Mobile, Inc.
+
+test_smoke_tests_hello_SOURCES = $(ENDLESS_TESTS_DIRECTORY)/smoke-tests/hello.c
+test_smoke_tests_hello_CPPFLAGS = $(TEST_FLAGS)
+test_smoke_tests_hello_LDADD = $(TEST_LIBS)