summaryrefslogtreecommitdiff
path: root/test
diff options
context:
space:
mode:
authorCosimo Cecchi <cosimoc@gnome.org>2015-09-02 10:36:30 -0700
committerCosimo Cecchi <cosimoc@gnome.org>2015-09-02 10:36:30 -0700
commit2d1a9a608517a531ed5b487cfeb415ce40727476 (patch)
tree0c5087024d90feb7a3c88208d20b096f13870e3a /test
parent6044ca4e3097a3e10c4ae50721f4324b62155253 (diff)
parentfd1247c9a62fb545f07ed4ad44b57e5519e4036f (diff)
Merge pull request #3567 from endlessm/sdk/3566
Attempt to fix hanging tests
Diffstat (limited to 'test')
-rw-r--r--test/Makefile.am.inc8
1 files changed, 7 insertions, 1 deletions
diff --git a/test/Makefile.am.inc b/test/Makefile.am.inc
index 73a2172..1071c9f 100644
--- a/test/Makefile.am.inc
+++ b/test/Makefile.am.inc
@@ -87,6 +87,12 @@ EXTRA_DIST += \
$(NULL)
CLEANFILES += stderr.log
+# Order some tests so that they don't try to export the same DBus names
+test/webhelper/testTranslate2Old.log: test/webhelper/testTranslate2.log
+test/webhelper/testWebActions2.log: test/webhelper/testTranslate2Old.log
+test/webhelper/testWebActions2Old.log: test/webhelper/testWebActions2.log
+test/webhelper/testLocal.log: test/webhelper/testWebActions2Old.log
+
# Use locally built versions of Endless-0.gir and libraries; this may need to be
# changed to AM_TESTS_ENVIRONMENT in a future version of Automake
# Set XDG_CONFIG_HOME so as to avoid cluttering the user's actual config
@@ -97,5 +103,5 @@ TESTS_ENVIRONMENT = \
export XDG_CONFIG_HOME=`mktemp -d $${TMPDIR:-/tmp}/sdktestconfig.XXXXXXXX`; \
export WEBHELPER_UNINSTALLED_EXTENSION_DIR="$(top_builddir)/.libs"; \
export TOP_SRCDIR="$(abs_top_srcdir)"; \
- export BUILDDIR=".";
+ export BUILDDIR="."; \
$(NULL)