summaryrefslogtreecommitdiff
path: root/test
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gmail.com>2016-10-13 18:54:08 -0700
committerEmmanuele Bassi <ebassi@gnome.org>2017-03-02 18:02:43 +0000
commit9a4e45d2814afb68f16c0c03e48193779acb54f1 (patch)
tree33e7f26c4b98e59715a7c6f3209e2e890ac58f11 /test
parent0e38a855c4ad0ac59e7ab5d166ab448911a47e0f (diff)
Add configure option to disable webhelper
We don't want to build the WebHelper code in the new Endless SDK, as it still strings along deprecated WebKitGtk dependencies, and nothing that uses the SDK also uses it. Based on commit 40c7e4342439dc3db19d3592b7599ff33e744cac. https://phabricator.endlessm.com/T15749
Diffstat (limited to 'test')
-rw-r--r--test/Makefile.am.inc22
1 files changed, 15 insertions, 7 deletions
diff --git a/test/Makefile.am.inc b/test/Makefile.am.inc
index 5a24fe7..ecde40a 100644
--- a/test/Makefile.am.inc
+++ b/test/Makefile.am.inc
@@ -45,12 +45,6 @@ EXTRA_DIST += \
javascript_tests = \
test/tools/eos-application-manifest/testInit.js \
test/tools/testHtmlExtractor.js \
- test/webhelper/testLocal.js \
- test/webhelper/testTranslate.js \
- test/webhelper/testTranslate2.js \
- test/webhelper/testWebActions.js \
- test/webhelper/testWebActions2.js \
- test/webhelper/testUpdateFontSize.js \
test/endless/testCustomContainer.js \
test/endless/testTopbarHomeButton.js \
test/endless/testTopbarNavButton.js \
@@ -62,6 +56,17 @@ EXTRA_DIST += \
test/utils.js \
$(NULL)
+if ENABLE_WEBHELPER
+javascript_tests += \
+ test/webhelper/testLocal.js \
+ test/webhelper/testTranslate.js \
+ test/webhelper/testTranslate2.js \
+ test/webhelper/testWebActions.js \
+ test/webhelper/testWebActions2.js \
+ test/webhelper/testUpdateFontSize.js \
+ $(NULL)
+endif ENABLE_WEBHELPER
+
# Run tests when running 'make check'
TESTS = \
test/endless/run-tests \
@@ -73,7 +78,6 @@ JS_LOG_DRIVER_FLAGS = --comments
TEST_EXTENSIONS = .js .coverage
JS_LOG_COMPILER = jasmine
AM_JS_LOG_FLAGS = \
- --include-path=$(top_srcdir)/webhelper \
--include-path=$(top_srcdir) \
--tap \
@JASMINE_REPORT_ARGUMENT@ \
@@ -92,6 +96,10 @@ dist_noinst_SCRIPTS = \
test/wait-for-service-helper.py \
$(NULL)
+if ENABLE_WEBHELPER
+AM_JS_LOG_FLAGS += --include-path=$(top_srcdir)/webhelper
+endif ENABLE_WEBHELPER
+
# Use locally built versions of Endless-0.gir and libraries; this may need to be
# changed to AM_TESTS_ENVIRONMENT in a future version of Automake
# Set XDG_CONFIG_HOME so as to avoid cluttering the user's actual config