summaryrefslogtreecommitdiff
path: root/tools/Makefile.am.inc
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2018-01-18 17:09:09 +0000
committerEmmanuele Bassi <ebassi@gnome.org>2018-01-18 17:09:09 +0000
commit05e5db0f0a8e75de68f8baa3a0b59bf398caebf6 (patch)
tree17f9600892c74627b70d402d90c30064ab016179 /tools/Makefile.am.inc
parenteadb00a03d4fe599f3dccd6d3330bee598b4464a (diff)
Add CLI tool for loading profiling aptures
Captures of profiling data are saved in a binary format, and we need a tool that can load them and turn them into user readable (or machine readable) data.
Diffstat (limited to 'tools/Makefile.am.inc')
-rw-r--r--tools/Makefile.am.inc14
1 files changed, 14 insertions, 0 deletions
diff --git a/tools/Makefile.am.inc b/tools/Makefile.am.inc
index 8f0015c..c2db497 100644
--- a/tools/Makefile.am.inc
+++ b/tools/Makefile.am.inc
@@ -41,3 +41,17 @@ dist_commands_DATA = \
$(NULL)
EXTRA_DIST += $(tools_test_modules)
+
+bin_PROGRAMS = \
+ eos-profile \
+ $(NULL)
+
+eos_profile_SOURCES = \
+ tools/eos-profile-tool/eos-profile-main.c \
+ tools/eos-profile-tool/eos-profile-cmds.h \
+ tools/eos-profile-tool/eos-profile-cmd-help.c \
+ $(NULL)
+
+eos_profile_CPPFLAGS = @EOS_SDK_CFLAGS@ -DG_LOG_DOMAIN=\"EosProfile\"
+eos_profile_CFLAGS = $(AM_CFLAGS)
+eos_profile_LDADD = $(top_builddir)/libendless-@EOS_SDK_API_VERSION@.la @EOS_SDK_LIBS@