summaryrefslogtreecommitdiff
path: root/tools/Makefile.am.inc
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2018-01-19 20:02:11 +0000
committerEmmanuele Bassi <ebassi@gnome.org>2018-01-19 20:02:11 +0000
commit49150ba51524a3ae423a8fb649c543718d41b4d9 (patch)
treeca36b307643bd61bb9261f6eefebcaf98620cb1b /tools/Makefile.am.inc
parent552d944f76f1c0961cd2b3bd39fa44eaa8a95f56 (diff)
Add show command to eos-profile
The `show` command loads a list of profile capture files and prints the metadata and sample summary.
Diffstat (limited to 'tools/Makefile.am.inc')
-rw-r--r--tools/Makefile.am.inc21
1 files changed, 18 insertions, 3 deletions
diff --git a/tools/Makefile.am.inc b/tools/Makefile.am.inc
index c2db497..d8751bb 100644
--- a/tools/Makefile.am.inc
+++ b/tools/Makefile.am.inc
@@ -47,11 +47,26 @@ bin_PROGRAMS = \
$(NULL)
eos_profile_SOURCES = \
- tools/eos-profile-tool/eos-profile-main.c \
tools/eos-profile-tool/eos-profile-cmds.h \
tools/eos-profile-tool/eos-profile-cmd-help.c \
+ tools/eos-profile-tool/eos-profile-cmd-show.c \
+ tools/eos-profile-tool/eos-profile-main.c \
+ tools/eos-profile-tool/eos-profile-utils.c \
+ tools/eos-profile-tool/eos-profile-utils.h \
+ endless/gvdb/gvdb-reader.c \
+ $(NULL)
+
+eos_profile_CPPFLAGS = \
+ @EOS_SDK_CFLAGS@ \
+ -DCOMPILING_EOS_SDK \
+ -DG_LOG_DOMAIN=\"EosProfile\" \
+ -I$(top_builddir) \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/endless/ \
+ -I$(top_builddir)/endless/ \
+ -I$(top_srcdir)/endless/gvdb \
+ -I$(top_srcdir)/tools/eos-profile-tool \
$(NULL)
-eos_profile_CPPFLAGS = @EOS_SDK_CFLAGS@ -DG_LOG_DOMAIN=\"EosProfile\"
eos_profile_CFLAGS = $(AM_CFLAGS)
-eos_profile_LDADD = $(top_builddir)/libendless-@EOS_SDK_API_VERSION@.la @EOS_SDK_LIBS@
+eos_profile_LDADD = $(top_builddir)/libendless-@EOS_SDK_API_VERSION@.la -lm @EOS_SDK_LIBS@