summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--endless/Makefile.am2
-rw-r--r--endless/eosactionbutton-private.h (renamed from endless/eosactionbutton.h)4
-rw-r--r--endless/eosactionbutton.c22
3 files changed, 12 insertions, 16 deletions
diff --git a/endless/Makefile.am b/endless/Makefile.am
index 4a030bd..48712dd 100644
--- a/endless/Makefile.am
+++ b/endless/Makefile.am
@@ -10,7 +10,7 @@ endless_private_installed_headers = \
endless/eospagemanager.h \
endless/eostypes.h \
endless/eoswindow.h \
- endless/eosactionbutton.h
+ endless/eosactionbutton-private.h
endless_library_sources = \
endless/eosapplication.c \
diff --git a/endless/eosactionbutton.h b/endless/eosactionbutton-private.h
index e03a8da..d5670e7 100644
--- a/endless/eosactionbutton.h
+++ b/endless/eosactionbutton-private.h
@@ -1,9 +1,5 @@
/* Copyright 2013 Endless Mobile, Inc. */
-#if !(defined(_EOS_SDK_INSIDE_ENDLESS_H) || defined(COMPILING_EOS_SDK))
-#error "Please do not include this header file directly."
-#endif
-
#ifndef EOS_ACTION_BUTTON_H
#define EOS_ACTION_BUTTON_H
diff --git a/endless/eosactionbutton.c b/endless/eosactionbutton.c
index 26be229..d8279b4 100644
--- a/endless/eosactionbutton.c
+++ b/endless/eosactionbutton.c
@@ -1,7 +1,7 @@
/* Copyright 2013 Endless Mobile, Inc. */
#include "config.h"
-#include "eosactionbutton.h"
+#include "eosactionbutton-private.h"
#include <glib-object.h>
#include <gtk/gtk.h>
@@ -201,11 +201,11 @@ eos_action_button_new (EosActionButtonSize size,
const gchar *label,
const gchar *icon_id)
{
- return GTK_WIDGET (g_object_new (EOS_TYPE_ACTION_BUTTON,
- "size", size,
- "label", label,
- "icon-id", icon_id,
- NULL));
+ return g_object_new (EOS_TYPE_ACTION_BUTTON,
+ "size", size,
+ "label", label,
+ "icon-id", icon_id,
+ NULL);
}
static void
@@ -372,9 +372,9 @@ eos_action_button_get_icon_id (EosActionButton *button)
static void
eos_action_button_get_property (GObject *object,
- guint property_id,
- GValue *value,
- GParamSpec *pspec)
+ guint property_id,
+ GValue *value,
+ GParamSpec *pspec)
{
EosActionButton *button = EOS_ACTION_BUTTON (object);
EosActionButtonPrivate *priv = button->priv;
@@ -529,7 +529,7 @@ eos_action_button_draw (GtkWidget *widget,
x, y, width, height);
}
- // TODO fix this:
+ // TODO is it really needed to restore and save the cairo_t here?
cairo_restore (cr);
cairo_save (cr);
@@ -542,7 +542,7 @@ eos_action_button_draw (GtkWidget *widget,
gtk_widget_draw (GTK_WIDGET (priv->icon_image), cr);
- // TODO and this:
+ // TODO same as previous
cairo_restore (cr);
cairo_save (cr);