summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.gitignore2
-rw-r--r--Makefile.am9
-rwxr-xr-xautogen.sh9
-rw-r--r--configure.ac9
-rw-r--r--docs/reference/endless/Makefile.am16
-rw-r--r--docs/reference/endless/endless-sections.txt2
-rw-r--r--docs/reference/endless/gtkdoc-test-dummy-file0
-rw-r--r--endless/eosactionbutton.c18
-rw-r--r--test/smoke-tests/webview.js2
-rw-r--r--webhelper/Makefile.am.inc10
-rw-r--r--webhelper/webhelper.js (renamed from test/smoke-tests/WebHelper.js)0
-rw-r--r--wikipedia/Makefile.am.inc4
12 files changed, 51 insertions, 30 deletions
diff --git a/.gitignore b/.gitignore
index 34c39f5..73220f3 100644
--- a/.gitignore
+++ b/.gitignore
@@ -117,7 +117,7 @@ pip-log.txt
.coverage
.tox
nosetests.xml
-test-results.xml
+*.log
# Translations
*.mo
diff --git a/Makefile.am b/Makefile.am
index f7d41d7..feee832 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -57,8 +57,10 @@ pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = @EOS_SDK_API_NAME@.pc
DISTCLEANFILES += @EOS_SDK_API_NAME@.pc
-# Open Endless Wikipedia SDK library
+# SDK sublibraries
+gjsmodulesdir = $(datadir)/gjs-1.0
include $(top_srcdir)/wikipedia/Makefile.am.inc
+include $(top_srcdir)/webhelper/Makefile.am.inc
# # # INTROSPECTION FILES # # #
@@ -156,7 +158,6 @@ m4_DATA = \
include $(top_srcdir)/test/Makefile.am
# Run tests when running 'make check'
-TESTS_ENVIRONMENT = gtester -k -o test-results.xml --verbose
TESTS = test/run-tests
-
-CLEANFILES += test-results.xml
+LOG_COMPILER = gtester
+AM_LOG_FLAGS = -k --verbose
diff --git a/autogen.sh b/autogen.sh
index 9a98233..6c20886 100755
--- a/autogen.sh
+++ b/autogen.sh
@@ -32,15 +32,6 @@ if test -z "$NOCONFIGURE"; then
echo "environment."
fi
-am_ver=`automake --version | grep -m 1 -o '[^ ]*$'`
-# Autmake 1.11.x doesn't grasp the 'serial-tests' option. Add a m4 file which
-# defines HAS_SERIAL_TESTS_OPTION so we can keep our configure.ac forward
-# compatible
-case $am_ver in
- 1.11*|1.12*) echo '';;
- *) echo 'm4_define([HAS_SERIAL_TESTS_OPTION], [1])';;
-esac > m4/serial-tests.m4
-
# Run the actual tools to prepare the clean checkout
gtkdocize || exit $?
autoreconf -fi || exit $?
diff --git a/configure.ac b/configure.ac
index 028360a..eb450a6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,12 +36,9 @@ AC_INIT([Open Endless SDK], [_EOS_SDK_VERSION_MACRO],
dnl AC_CONFIG_SRCDIR([src/hello.c])
# Initialize Automake: enable all warnings and do not insist on GNU standards
# no-portability suppresses warnings about syntax specific to GNU make
-# If Automake >= 1.13 we need the serial-tests options
-# We use an serial-test.m4 file set up in autogen.sh to test if we need it
-m4_include([m4/serial-tests.m4])
-m4_ifdef([HAS_SERIAL_TESTS_OPTION],
- [AM_INIT_AUTOMAKE([-Wall -Wno-portability foreign 1.11 serial-tests])],
- [AM_INIT_AUTOMAKE([-Wall -Wno-portability foreign 1.11])])
+# parallel-tests specifies that we use the new parallel-running test harness.
+# Unlike serial-tests, this option is accepted by Automake 1.11
+AM_INIT_AUTOMAKE([-Wall -Wno-portability foreign 1.11 parallel-tests])
# Avoid spewing garbage over the terminal ('make V=1' to see the garbage)
AM_SILENT_RULES([yes])
# Initialize Libtool; don't build static libraries
diff --git a/docs/reference/endless/Makefile.am b/docs/reference/endless/Makefile.am
index 7131b0c..420200c 100644
--- a/docs/reference/endless/Makefile.am
+++ b/docs/reference/endless/Makefile.am
@@ -86,12 +86,14 @@ EXTRA_DIST +=
# for --rebuild-sections in $(SCAN_OPTIONS) e.g. $(DOC_MODULE)-sections.txt
#DISTCLEANFILES +=
-# Comment this out if you want 'make check' to test you doc status
-# and run some sanity checks
if ENABLE_GTK_DOC
-TESTS_ENVIRONMENT = cd $(srcdir) && \
- DOC_MODULE=$(DOC_MODULE) DOC_MAIN_SGML_FILE=$(DOC_MAIN_SGML_FILE) \
- SRCDIR=$(abs_srcdir) BUILDDIR=$(abs_builddir)
-TESTS = $(GTKDOC_CHECK)
+AM_TESTS_ENVIRONMENT = \
+ export DOC_MODULE=$(DOC_MODULE); \
+ export DOC_MAIN_SGML_FILE=$(DOC_MAIN_SGML_FILE); \
+ export SRCDIR=$(abs_srcdir); \
+ export BUILDDIR=$(abs_builddir)
+# Need a dummy file to feed to GTKDOC_CHECK in the parallel test harness
+TESTS = gtkdoc-test-dummy-file
+LOG_COMPILER = $(GTKDOC_CHECK)
+EXTRA_DIST += gtkdoc-test-dummy-file
endif
-
diff --git a/docs/reference/endless/endless-sections.txt b/docs/reference/endless/endless-sections.txt
index a02e5c7..805bcf4 100644
--- a/docs/reference/endless/endless-sections.txt
+++ b/docs/reference/endless/endless-sections.txt
@@ -121,6 +121,8 @@ eos_action_button_get_label
eos_action_button_set_label
eos_action_button_get_size
eos_action_button_set_size
+eos_action_button_get_label_position
+eos_action_button_set_label_position
EosActionButtonSize
<SUBSECTION Standard>
EOS_ACTION_BUTTON
diff --git a/docs/reference/endless/gtkdoc-test-dummy-file b/docs/reference/endless/gtkdoc-test-dummy-file
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/docs/reference/endless/gtkdoc-test-dummy-file
diff --git a/endless/eosactionbutton.c b/endless/eosactionbutton.c
index 901538c..83c437d 100644
--- a/endless/eosactionbutton.c
+++ b/endless/eosactionbutton.c
@@ -421,6 +421,15 @@ eos_action_button_get_label (EosActionButton *button)
return priv->label;
}
+/**
+ * eos_action_button_set_label_position:
+ * @button: the button
+ * @position: position of the label: top, bottom, left or right
+ *
+ * Changes the position of the label to be above, below, or to one side of the
+ * action button.
+ * See #EosActionButton:label-position for more information.
+ */
void
eos_action_button_set_label_position (EosActionButton *button,
GtkPositionType position)
@@ -458,6 +467,15 @@ eos_action_button_set_label_position (EosActionButton *button,
}
}
+/**
+ * eos_action_button_get_label_position:
+ * @button: the button
+ *
+ * Gets the position of the label respective to the button.
+ * See #EosActionButton:label-position for more information.
+ *
+ * Returns: the position of the label: top, bottom, left, or right
+ */
GtkPositionType
eos_action_button_get_label_position (EosActionButton *button)
{
diff --git a/test/smoke-tests/webview.js b/test/smoke-tests/webview.js
index 9b84728..98226f3 100644
--- a/test/smoke-tests/webview.js
+++ b/test/smoke-tests/webview.js
@@ -7,7 +7,7 @@ const Gtk = imports.gi.Gtk;
const WebKit = imports.gi.WebKit;
// WebHelper.js must be copied somewhere in GJS's imports.searchPath
-const WebHelper = imports.WebHelper;
+const WebHelper = imports.webhelper;
const TEST_APPLICATION_ID = 'com.endlessm.example.test-webview';
diff --git a/webhelper/Makefile.am.inc b/webhelper/Makefile.am.inc
new file mode 100644
index 0000000..f7b26b0
--- /dev/null
+++ b/webhelper/Makefile.am.inc
@@ -0,0 +1,10 @@
+# Copyright 2013 Endless Mobile, Inc.
+
+# # # INSTALL RULES # # #
+
+webhelper_sources = webhelper/webhelper.js
+
+webhelperdir = $(gjsmodulesdir)
+dist_webhelper_DATA = \
+ $(webhelper_sources) \
+ $(NULL)
diff --git a/test/smoke-tests/WebHelper.js b/webhelper/webhelper.js
index 8b78931..8b78931 100644
--- a/test/smoke-tests/WebHelper.js
+++ b/webhelper/webhelper.js
diff --git a/wikipedia/Makefile.am.inc b/wikipedia/Makefile.am.inc
index 493b539..dd1c5bb 100644
--- a/wikipedia/Makefile.am.inc
+++ b/wikipedia/Makefile.am.inc
@@ -48,7 +48,7 @@ js_sources = \
wikipedia/WikipediaWebView.js \
$(NULL)
-gjsmodulesdir = $(datadir)/gjs-1.0
-nobase_dist_gjsmodules_DATA = \
+wikipediadir = $(gjsmodulesdir)
+nobase_dist_wikipedia_DATA = \
$(js_sources) \
$(NULL)