summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am12
-rw-r--r--webhelper/Makefile.am.inc12
2 files changed, 10 insertions, 14 deletions
diff --git a/Makefile.am b/Makefile.am
index ce67ced..51ac18b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -59,9 +59,17 @@ pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = @EOS_SDK_API_NAME@.pc
DISTCLEANFILES += @EOS_SDK_API_NAME@.pc
-# SDK sublibraries
+# # # WEBHELPER LIBRARY # # #
+
+webhelper_sources = webhelper/webhelper.js
+
gjsmodulesdir = $(datadir)/gjs-1.0
-include $(top_srcdir)/webhelper/Makefile.am.inc
+webhelperdir = $(gjsmodulesdir)
+dist_webhelper_DATA = \
+ $(webhelper_sources) \
+ $(NULL)
+
+EOS_JS_COVERAGE_FILES = $(webhelper_sources)
# # # INTROSPECTION FILES # # #
diff --git a/webhelper/Makefile.am.inc b/webhelper/Makefile.am.inc
deleted file mode 100644
index 3531000..0000000
--- a/webhelper/Makefile.am.inc
+++ /dev/null
@@ -1,12 +0,0 @@
-# Copyright 2013 Endless Mobile, Inc.
-
-# # # INSTALL RULES # # #
-
-webhelper_sources = webhelper/webhelper.js
-
-webhelperdir = $(gjsmodulesdir)
-dist_webhelper_DATA = \
- $(webhelper_sources) \
- $(NULL)
-
-EOS_JS_COVERAGE_FILES = $(webhelper_sources)