summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--configure.ac4
-rw-r--r--test/Makefile.am.inc1
-rw-r--r--test/endless/Makefile.am.inc18
-rw-r--r--test/smoke-tests/Makefile.am.inc2
4 files changed, 13 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index 4f6fe4e..c71973e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -40,7 +40,9 @@ dnl AC_CONFIG_SRCDIR([src/hello.c])
# Unlike serial-tests, this option is accepted by Automake 1.11
# tar-ustar is required because there may be files whose entire paths exceed
# 99 characters.
-AM_INIT_AUTOMAKE([-Wall -Wno-portability foreign 1.11 parallel-tests tar-ustar])
+# subdir-objects is for forward compatibility with Automake 2.0 and can be
+# removed when we upgrade to that version.
+AM_INIT_AUTOMAKE([-Wall -Wno-portability foreign 1.11 parallel-tests tar-ustar subdir-objects])
# Avoid spewing garbage over the terminal ('make V=1' to see the garbage)
AM_SILENT_RULES([yes])
# Initialize Libtool; don't build static libraries
diff --git a/test/Makefile.am.inc b/test/Makefile.am.inc
index 5b3128a..c18defd 100644
--- a/test/Makefile.am.inc
+++ b/test/Makefile.am.inc
@@ -2,7 +2,6 @@
TEST_FLAGS = @EOS_SDK_CFLAGS@ -I$(top_srcdir) -DCOMPILING_EOS_SDK
TEST_LIBS = @EOS_SDK_LIBS@ $(top_builddir)/libendless-@EOS_SDK_API_VERSION@.la
-ENDLESS_TESTS_DIRECTORY = $(top_srcdir)/test
noinst_PROGRAMS = \
test/endless/run-tests \
diff --git a/test/endless/Makefile.am.inc b/test/endless/Makefile.am.inc
index 5e83d2f..628ad0f 100644
--- a/test/endless/Makefile.am.inc
+++ b/test/endless/Makefile.am.inc
@@ -1,15 +1,15 @@
# Copyright 2013 Endless Mobile, Inc.
test_endless_run_tests_SOURCES = \
- $(ENDLESS_TESTS_DIRECTORY)/endless/run-tests.c \
- $(ENDLESS_TESTS_DIRECTORY)/endless/run-tests.h \
- $(ENDLESS_TESTS_DIRECTORY)/endless/test-init.c \
- $(ENDLESS_TESTS_DIRECTORY)/endless/test-hello.c \
- $(ENDLESS_TESTS_DIRECTORY)/endless/test-application.c \
- $(ENDLESS_TESTS_DIRECTORY)/endless/test-page-manager.c \
- $(ENDLESS_TESTS_DIRECTORY)/endless/test-window.c \
- $(ENDLESS_TESTS_DIRECTORY)/endless/test-flexy-grid.c \
- $(ENDLESS_TESTS_DIRECTORY)/endless/test-custom-container.c \
+ test/endless/run-tests.c \
+ test/endless/run-tests.h \
+ test/endless/test-init.c \
+ test/endless/test-hello.c \
+ test/endless/test-application.c \
+ test/endless/test-page-manager.c \
+ test/endless/test-window.c \
+ test/endless/test-flexy-grid.c \
+ test/endless/test-custom-container.c \
$(NULL)
test_endless_run_tests_CPPFLAGS = $(TEST_FLAGS)
test_endless_run_tests_LDADD = $(TEST_LIBS)
diff --git a/test/smoke-tests/Makefile.am.inc b/test/smoke-tests/Makefile.am.inc
index 170b335..5ee5ac2 100644
--- a/test/smoke-tests/Makefile.am.inc
+++ b/test/smoke-tests/Makefile.am.inc
@@ -1,6 +1,6 @@
# Copyright 2013 Endless Mobile, Inc.
-test_smoke_tests_hello_SOURCES = $(ENDLESS_TESTS_DIRECTORY)/smoke-tests/hello.c
+test_smoke_tests_hello_SOURCES = test/smoke-tests/hello.c
test_smoke_tests_hello_CPPFLAGS = $(TEST_FLAGS)
test_smoke_tests_hello_LDADD = $(TEST_LIBS)