summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index d4a27a0..11a922e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -20,6 +20,8 @@ EXTRA_DIST = @EOS_SDK_API_NAME@.pc.in
DEFS = -DLOCALEDIR=\"$(localedir)\" @DEFS@
AM_CFLAGS = @STRICT_CFLAGS@
+# Generated files that 'make clean' should erase
+CLEANFILES =
DISTCLEANFILES =
# # # LIBRARY # # #
@@ -37,3 +39,13 @@ nobase_endlessinclude_HEADERS = \
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = @EOS_SDK_API_NAME@.pc
DISTCLEANFILES += @EOS_SDK_API_NAME@.pc
+
+# # # TESTS # # #
+
+include $(top_srcdir)/test/Makefile.am
+
+# Run tests when running 'make check'
+TESTS_ENVIRONMENT = gtester -k -o test-results.xml
+TESTS = test/run-tests
+
+CLEANFILES += test-results.xml