summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index f7d41d7..feee832 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -57,8 +57,10 @@ pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = @EOS_SDK_API_NAME@.pc
DISTCLEANFILES += @EOS_SDK_API_NAME@.pc
-# Open Endless Wikipedia SDK library
+# SDK sublibraries
+gjsmodulesdir = $(datadir)/gjs-1.0
include $(top_srcdir)/wikipedia/Makefile.am.inc
+include $(top_srcdir)/webhelper/Makefile.am.inc
# # # INTROSPECTION FILES # # #
@@ -156,7 +158,6 @@ m4_DATA = \
include $(top_srcdir)/test/Makefile.am
# Run tests when running 'make check'
-TESTS_ENVIRONMENT = gtester -k -o test-results.xml --verbose
TESTS = test/run-tests
-
-CLEANFILES += test-results.xml
+LOG_COMPILER = gtester
+AM_LOG_FLAGS = -k --verbose