summaryrefslogtreecommitdiff
path: root/ansible/playbooks/setup_other_tools.yaml
diff options
context:
space:
mode:
Diffstat (limited to 'ansible/playbooks/setup_other_tools.yaml')
-rw-r--r--ansible/playbooks/setup_other_tools.yaml18
1 files changed, 18 insertions, 0 deletions
diff --git a/ansible/playbooks/setup_other_tools.yaml b/ansible/playbooks/setup_other_tools.yaml
new file mode 100644
index 0000000..ef7eec6
--- /dev/null
+++ b/ansible/playbooks/setup_other_tools.yaml
@@ -0,0 +1,18 @@
+---
+# vim:ff=unix ts=2 sw=2 ai expandtab
+
+- name: "Ensuring that git is installed"
+ apt: name=git
+
+- name: "Creating turbine directory"
+ file: path=~/checkout state=directory mode=755
+
+- name: "Cloning turbine"
+ git: repo=git://git.gnome.org/turbine
+ dest=~/checkout/turbine
+
+- name: "Installing turbine"
+ shell: cd ~/checkout/turbine && python setup.py install
+
+- name: "Installing transifex client"
+ shell: pip install transifex-client