summaryrefslogtreecommitdiff
path: root/autogen.sh
diff options
context:
space:
mode:
Diffstat (limited to 'autogen.sh')
-rwxr-xr-xautogen.sh9
1 files changed, 9 insertions, 0 deletions
diff --git a/autogen.sh b/autogen.sh
index 6c20886..6ff77fb 100755
--- a/autogen.sh
+++ b/autogen.sh
@@ -32,6 +32,15 @@ if test -z "$NOCONFIGURE"; then
echo "environment."
fi
+am_ver=`automake --version | grep -m 1 -o '[^ ]*$'`
+# Autmake 1.11.x doesn't grasp the 'serial-tests' option. Add a m4 file which
+# defines HAS_SERIAL_TESTS_OPTION so we can keep our configure.ac forward
+# compatible
+case $am_ver in
+ *\ 1.11*|*\ 1.12*) ;;
+ *) echo 'm4_define([HAS_SERIAL_TESTS_OPTION], [1])';;
+esac > m4/serial-tests.m4
+
# Run the actual tools to prepare the clean checkout
gtkdocize || exit $?
autoreconf -fi || exit $?