summaryrefslogtreecommitdiff
path: root/test/Makefile.am.inc
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am.inc')
-rw-r--r--test/Makefile.am.inc7
1 files changed, 4 insertions, 3 deletions
diff --git a/test/Makefile.am.inc b/test/Makefile.am.inc
index 826824f..08dd5e8 100644
--- a/test/Makefile.am.inc
+++ b/test/Makefile.am.inc
@@ -14,7 +14,6 @@ include test/demos/Makefile.am.inc
include test/smoke-tests/Makefile.am.inc
javascript_tests = \
- test/tools/eos-run-test/sanitycheck.js \
test/tools/eos-application-manifest/testInit.js \
test/webhelper/testTranslate.js \
test/webhelper/testWebActions.js \
@@ -29,8 +28,7 @@ TESTS = \
test/endless/run-tests \
$(javascript_tests) \
$(NULL)
-TEST_EXTENSIONS = .js
-JS_LOG_COMPILER = tools/eos-run-test
+TEST_EXTENSIONS =
AM_JS_LOG_FLAGS = \
--include-path=$(top_srcdir)/webhelper \
--include-path=$(top_srcdir) \
@@ -38,6 +36,9 @@ AM_JS_LOG_FLAGS = \
LOG_COMPILER = gtester
AM_LOG_FLAGS = -k --verbose
+JASMINE_SUBMODULE_PATH = $(top_srcdir)/test/jasmine
+include test/jasmine/Makefile-jasmine.am.inc
+
# Use locally built versions of Endless-0.gir and libraries; this may need to be
# changed to AM_TESTS_ENVIRONMENT in a future version of Automake
# Set XDG_CONFIG_HOME so as to avoid cluttering the user's actual config