summaryrefslogtreecommitdiff
path: root/test/Makefile.am.inc
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am.inc')
-rw-r--r--test/Makefile.am.inc11
1 files changed, 4 insertions, 7 deletions
diff --git a/test/Makefile.am.inc b/test/Makefile.am.inc
index ecde40a..0d74647 100644
--- a/test/Makefile.am.inc
+++ b/test/Makefile.am.inc
@@ -83,19 +83,15 @@ AM_JS_LOG_FLAGS = \
@JASMINE_REPORT_ARGUMENT@ \
--no-config \
$(NULL)
-LOG_COMPILER = $(top_srcdir)/test/gtester-mock-event-recorder.sh
-AM_LOG_FLAGS = -k --verbose
+LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) $(top_srcdir)/tap-driver.sh
+LOG_COMPILER = $(top_srcdir)/test/tap-test.sh
EXTRA_DIST += \
+ test/tap-test.sh
test/run-with-dbus \
test/test-bus.conf \
$(NULL)
CLEANFILES += stderr.log
-dist_noinst_SCRIPTS = \
- test/gtester-mock-event-recorder.sh \
- test/wait-for-service-helper.py \
- $(NULL)
-
if ENABLE_WEBHELPER
AM_JS_LOG_FLAGS += --include-path=$(top_srcdir)/webhelper
endif ENABLE_WEBHELPER
@@ -105,6 +101,7 @@ endif ENABLE_WEBHELPER
# Set XDG_CONFIG_HOME so as to avoid cluttering the user's actual config
# directory with junk from the tests
TESTS_ENVIRONMENT = \
+ export EOS_DISABLE_METRICS=1; \
export GI_TYPELIB_PATH="$(top_builddir)$${GI_TYPELIB_PATH:+:$$GI_TYPELIB_PATH}"; \
export LD_LIBRARY_PATH="$(top_builddir)/.libs$${LD_LIBRARY_PATH:+:$$LD_LIBRARY_PATH}"; \
export XDG_CONFIG_HOME=`mktemp -d $${TMPDIR:-/tmp}/sdktestconfig.XXXXXXXX`; \