summaryrefslogtreecommitdiff
path: root/test/Makefile.am.inc
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am.inc')
-rw-r--r--test/Makefile.am.inc15
1 files changed, 8 insertions, 7 deletions
diff --git a/test/Makefile.am.inc b/test/Makefile.am.inc
index 08dd5e8..74f6fe6 100644
--- a/test/Makefile.am.inc
+++ b/test/Makefile.am.inc
@@ -5,16 +5,13 @@ TEST_LIBS = @EOS_SDK_LIBS@ $(top_builddir)/libendless-@EOS_SDK_API_VERSION@.la
ENDLESS_TESTS_DIRECTORY = $(top_srcdir)/test
noinst_PROGRAMS = \
- test/endless/run-tests \
+ test/endless/run-tests \
test/smoke-tests/hello \
- test/demos/flexy-grid
-
-include test/endless/Makefile.am.inc
-include test/demos/Makefile.am.inc
-include test/smoke-tests/Makefile.am.inc
+ test/demos/flexy-grid
+# This variable will be updated in Makefile subdirs (test/endless/Makefile.am.inc)
javascript_tests = \
- test/tools/eos-application-manifest/testInit.js \
+ test/tools/eos-application-manifest/testInit.js \
test/webhelper/testTranslate.js \
test/webhelper/testWebActions.js \
test/wikipedia/models/testCategoryModel.js \
@@ -23,6 +20,10 @@ javascript_tests = \
$(NULL)
EXTRA_DIST += $(javascript_tests)
+include test/endless/Makefile.am.inc
+include test/demos/Makefile.am.inc
+include test/smoke-tests/Makefile.am.inc
+
# Run tests when running 'make check'
TESTS = \
test/endless/run-tests \