summaryrefslogtreecommitdiff
path: root/test/Makefile.am.inc
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am.inc')
-rw-r--r--test/Makefile.am.inc39
1 files changed, 35 insertions, 4 deletions
diff --git a/test/Makefile.am.inc b/test/Makefile.am.inc
index c18defd..d070b95 100644
--- a/test/Makefile.am.inc
+++ b/test/Makefile.am.inc
@@ -8,18 +8,49 @@ noinst_PROGRAMS = \
test/smoke-tests/hello \
$(NULL)
-# This variable will be updated in Makefile subdirs (test/endless/Makefile.am.inc)
+test_endless_run_tests_SOURCES = \
+ test/endless/run-tests.c \
+ test/endless/run-tests.h \
+ test/endless/test-init.c \
+ test/endless/test-hello.c \
+ test/endless/test-application.c \
+ test/endless/test-page-manager.c \
+ test/endless/test-window.c \
+ test/endless/test-flexy-grid.c \
+ test/endless/test-custom-container.c \
+ $(NULL)
+test_endless_run_tests_CPPFLAGS = $(TEST_FLAGS)
+test_endless_run_tests_LDADD = $(TEST_LIBS)
+
+test_smoke_tests_hello_SOURCES = test/smoke-tests/hello.c
+test_smoke_tests_hello_CPPFLAGS = $(TEST_FLAGS)
+test_smoke_tests_hello_LDADD = $(TEST_LIBS)
+
+credits_resource_files = \
+ test/smoke-tests/images/test1.jpg \
+ test/smoke-tests/images/test2.jpg \
+ test/smoke-tests/images/test3.jpg \
+ test/smoke-tests/images/attribution.json \
+ $(NULL)
+test/smoke-tests/images/credits.gresource: test/smoke-tests/images/credits.gresource.xml $(credits_resource_files)
+ $(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir)/test/smoke-tests/images $<
+dist_noinst_DATA = test/smoke-tests/images/credits.gresource
+CLEANFILES += test/smoke-tests/images/credits.gresource
+EXTRA_DIST += \
+ test/smoke-tests/images/credits.gresource.xml \
+ $(credits_resource_files) \
+ $(NULL)
+
javascript_tests = \
test/tools/eos-application-manifest/testInit.js \
test/webhelper/testTranslate.js \
test/webhelper/testWebActions.js \
test/webhelper/testUpdateFontSize.js \
+ test/endless/testCustomContainer.js \
+ test/endless/testTopbarNavButton.js \
$(NULL)
EXTRA_DIST += $(javascript_tests)
-include test/endless/Makefile.am.inc
-include test/smoke-tests/Makefile.am.inc
-
# Run tests when running 'make check'
TESTS = \
test/endless/run-tests \