summaryrefslogtreecommitdiff
path: root/test
diff options
context:
space:
mode:
Diffstat (limited to 'test')
-rw-r--r--test/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index e913d57..4124c52 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -31,3 +31,16 @@ javascript_tests = \
test/webhelper/testWebActions.js \
$(NULL)
EXTRA_DIST += $(javascript_tests)
+
+# Run tests when running 'make check'
+TESTS = \
+ test/run-tests \
+ $(javascript_tests) \
+ $(NULL)
+TEST_EXTENSIONS = .js
+JS_LOG_COMPILER = tools/eos-run-test
+AM_JS_LOG_FLAGS = \
+ --include-path=$(top_srcdir)/webhelper \
+ $(NULL)
+LOG_COMPILER = gtester
+AM_LOG_FLAGS = -k --verbose