summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--README.md20
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/auto-0.1.2-3-abe4474066b235b831ab73bf6851abb48a258698-156673678657
-rw-r--r--debian/patches/series1
4 files changed, 85 insertions, 0 deletions
diff --git a/README.md b/README.md
index 8fd759c..e7b0d90 100644
--- a/README.md
+++ b/README.md
@@ -5,6 +5,12 @@ just like `ert-deftest`, except that it works for async tests.
## Installation
+Add `ert-async` to your [Cask](https://github.com/cask/cask) file:
+
+```lisp
+(depends-on "ert-async")
+```
+
Add this to get font locking for `ert-deftest-async`:
```lisp
@@ -49,3 +55,17 @@ you don't want a function to callback, for example:
(funcall done "should not callback, but did")))
(funcall done))
```
+
+## Contribution
+
+Contribution is much welcome!
+
+Install [Cask](https://github.com/cask/cask) if you haven't
+already, then:
+
+ $ cd /path/to/ert-async.el
+ $ cask
+
+Run all tests with:
+
+ $ make
diff --git a/debian/changelog b/debian/changelog
index 858bd40..389ec1a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+ert-async-el (0.1.2-3) unstable; urgency=medium
+
+ * Team upload.
+ * Rebuild with current dh-elpa
+
+ -- David Bremner <bremner@debian.org> Sun, 25 Aug 2019 09:39:44 -0300
+
ert-async-el (0.1.2-2) unstable; urgency=medium
* Team upload.
diff --git a/debian/patches/auto-0.1.2-3-abe4474066b235b831ab73bf6851abb48a258698-1566736786 b/debian/patches/auto-0.1.2-3-abe4474066b235b831ab73bf6851abb48a258698-1566736786
new file mode 100644
index 0000000..5ac3761
--- /dev/null
+++ b/debian/patches/auto-0.1.2-3-abe4474066b235b831ab73bf6851abb48a258698-1566736786
@@ -0,0 +1,57 @@
+From: David Bremner <bremner@debian.org>
+Subject: Automatically generated patch (0.1.2-3)
+
+Last (up to) 3 git changes, FYI:
+
+commit abe4474066b235b831ab73bf6851abb48a258698
+Author: David Bremner <david@tethera.net>
+Date: Sun Aug 25 09:39:44 2019 -0300
+
+ changelog for rebuild with current dh-elpa
+
+commit 6a080104eb2ddf1219b6f6474c1eaaf839d86f34
+Author: David Bremner <david@tethera.net>
+Date: Sat Jun 2 20:47:25 2018 -0300
+
+ changelog for byte compilation rebuild
+
+commit 6d499f3efb7c29e44ef90b8b028021a6e5988891
+Author: Sean Whitton <spwhitton@spwhitton.name>
+Date: Sat Oct 8 18:02:43 2016 -0700
+
+ release
+---
+
+--- ert-async-el-0.1.2.orig/README.md
++++ ert-async-el-0.1.2/README.md
+@@ -5,6 +5,12 @@ just like `ert-deftest`, except that it
+
+ ## Installation
+
++Add `ert-async` to your [Cask](https://github.com/cask/cask) file:
++
++```lisp
++(depends-on "ert-async")
++```
++
+ Add this to get font locking for `ert-deftest-async`:
+
+ ```lisp
+@@ -49,3 +55,17 @@ you don't want a function to callback, f
+ (funcall done "should not callback, but did")))
+ (funcall done))
+ ```
++
++## Contribution
++
++Contribution is much welcome!
++
++Install [Cask](https://github.com/cask/cask) if you haven't
++already, then:
++
++ $ cd /path/to/ert-async.el
++ $ cask
++
++Run all tests with:
++
++ $ make
diff --git a/debian/patches/series b/debian/patches/series
index 252c97d..5238cad 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +1,2 @@
patch-README-for-Debian.patch
+auto-0.1.2-3-abe4474066b235b831ab73bf6851abb48a258698-1566736786