summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen M. Webb <stephen.webb@bregmasoft.ca>2016-12-15 08:17:34 +0100
committerJulien Cristau <jcristau@debian.org>2016-12-15 08:17:34 +0100
commitde2a966d65d3e46a8c0c9d8859f2f39469091c34 (patch)
treef47a2a648d7d595bda456c37e8f3b4dbc226c9fd
parentde0d7604fff718b0e095aee9c4e7dbebac8533ac (diff)
check-test-conditions
=== modified file 'configure.ac' Gbp-Pq: Name 0002-check-test-conditions.patch
-rw-r--r--configure.ac3
-rw-r--r--python/Makefile.am2
2 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 85ac5fb..f09c211 100644
--- a/configure.ac
+++ b/configure.ac
@@ -66,6 +66,9 @@ AC_ARG_ENABLE([tests],
AM_CONDITIONAL(BUILD_TESTS, [test "x$enable_tests" = "xyes"])
+# required self-test conditions
+AM_CONDITIONAL([HAVE_DEV_INPUT], [test -d /dev/input -a -w /dev/input])
+
AC_SUBST(AM_CFLAGS,
"-Wall -Wextra")
diff --git a/python/Makefile.am b/python/Makefile.am
index 382bcec..e1728b9 100644
--- a/python/Makefile.am
+++ b/python/Makefile.am
@@ -36,7 +36,9 @@ test_sources = \
evemu/tests/test_device.py
if BUILD_TESTS
+if HAVE_DEV_INPUT
check_SCRIPTS = evemu-test-runner
+endif
TESTS = $(check_SCRIPTS)