summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLaslo Hunhold <dev@frign.de>2017-04-16 23:22:25 +0200
committerLaslo Hunhold <dev@frign.de>2017-04-16 23:24:43 +0200
commit80aabad7cb520fd890dfb82d35da30a9300ee439 (patch)
tree51f75bbb053450d8da0ac2dc2abf456e7680ca39
parent00dd0ab39f634729ec5d99b8057b9cef6fa0f23e (diff)
Bring cc-command-line in order
Of course, you want the libraries to come last in order of execution. Additionally, in case the libraries provided with $($*-LDFLAGS) contain unresolved symbols, we want to give the opportunity for the user to provide the necessary general symbols, whatever they may be, last. Thanks Duncaen for reporting this!
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index ca1949b..baf2d41 100644
--- a/Makefile
+++ b/Makefile
@@ -23,7 +23,7 @@ $(BIN): $(REQ:=.o)
$(BIN:=.o): config.mk $(HDR) $(REQ:=.h)
.o:
- $(CC) $(LDFLAGS) $($*-LDFLAGS) -o $@ $< $(REQ:=.o)
+ $(CC) -o $@ $< $(REQ:=.o) $($*-LDFLAGS) $(LDFLAGS)
clean:
rm -f $(BIN) $(BIN:=.o) $(REQ:=.o)