summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLaslo Hunhold <dev@frign.de>2017-05-29 18:29:00 +0200
committerLaslo Hunhold <dev@frign.de>2017-05-29 18:29:00 +0200
commitbfb27d1baad6f69fa610281809a394617a76e60a (patch)
tree20db06191ddf215a131af1bb1ec675264c52091d
parent031b208cb24addbe4496eb24da6887b43a54f5e1 (diff)
Makefile-workaround for OpenBSD
Thanks Hiltjo for reporting this! For some reason, OpenBSD make does not add $(BIN).o to the dependency list when it sees the $(BIN) target rule. It does so however when it does the conversion from .c to .o. This behaviour is unique for OpenBSD make as far as I've seen, and for the time being, this workaround will manually add the object to the dependency list. This is not POSIX compliant and in GNU make it just evaluates to an empty string, but it works until this has been investigated further.
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 27dc544..5cf2e17 100644
--- a/Makefile
+++ b/Makefile
@@ -18,7 +18,7 @@ ff2jpg-LDLIBS = $(JPG-LDLIBS)
all: $(BIN)
-$(BIN): $(REQ:=.o)
+$(BIN): $(@:=.o) $(REQ:=.o)
$(BIN:=.o): config.mk $(HDR) $(REQ:=.h)