summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorFRIGN <dev@frign.de>2016-01-05 16:56:47 +0100
committerFRIGN <dev@frign.de>2016-01-05 16:56:47 +0100
commita7dba356ecad56b84c06fc12f537682feff61232 (patch)
treec6585dc5ac9470b41c43e5da8e83b66220146146 /Makefile
parent24c4b045fc495becc9ba4239ba3d2963851c7634 (diff)
Fix Makefile+config.mk
I forgot that we can't just cd. It has to be a &&-statement. Also, uncomplicate the output.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile23
1 files changed, 10 insertions, 13 deletions
diff --git a/Makefile b/Makefile
index b93b472..cfc4fe8 100644
--- a/Makefile
+++ b/Makefile
@@ -17,26 +17,23 @@ all: png2ff ff2png jpg2ff
clean:
rm -f ${BIN}
-install:
+install: all
@echo installing into ${DESTDIR}${PREFIX}/bin
@mkdir -p ${DESTDIR}${PREFIX}/bin
@cp -f 2ff ${BIN} ${DESTDIR}${PREFIX}/bin
- mkdir -p $(DESTDIR)$(MANPREFIX)/man1
+ @echo installing manpages into ${DESTDIR}${MANPREFIX}
+ @mkdir -p $(DESTDIR)$(MANPREFIX)/man1
@cp -f $(MAN1) $(DESTDIR)$(MANPREFIX)/man1
- cd $(DESTDIR)$(MANPREFIX)/man1 && chmod 644 $(MAN1)
- mkdir -p $(DESTDIR)$(MANPREFIX)/man5
+ @cd $(DESTDIR)$(MANPREFIX)/man1 && chmod 644 $(MAN1)
+ @mkdir -p $(DESTDIR)$(MANPREFIX)/man5
@cp -f $(MAN5) $(DESTDIR)$(MANPREFIX)/man5
- cd $(DESTDIR)$(MANPREFIX)/man5 && chmod 644 $(MAN5)
+ @cd $(DESTDIR)$(MANPREFIX)/man5 && chmod 644 $(MAN5)
uninstall:
@echo removing from ${DESTDIR}${PREFIX}/bin
- cd ${DESTDIR}${PREFIX}/bin
- @rm -f 2ff ${BIN}
- @echo removing from ${DESTDIR}${MANPREFIX}/man1
- cd ${DESTDIR}${MANPREFIX}/man1
- @rm -f $(MAN1)
- @echo removing from ${DESTDIR}${MANPREFIX}/man5
- cd ${DESTDIR}${MANPREFIX}/man5
- @rm -f $(MAN5)
+ @cd ${DESTDIR}${PREFIX}/bin && rm -f 2ff ${BIN}
+ @echo removing manpages from ${DESTDIR}${MANPREFIX}
+ @cd ${DESTDIR}${MANPREFIX}/man1 && rm -f $(MAN1)
+ @cd ${DESTDIR}${MANPREFIX}/man5 && rm -f $(MAN5)
.PHONY: all clean install uninstall