summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorLaslo Hunhold <dev@frign.de>2017-03-30 08:59:52 +0200
committerLaslo Hunhold <dev@frign.de>2017-03-30 08:59:52 +0200
commit0aaa36464a4ad965a3d747cc6df16137c7b5d6c5 (patch)
tree332ba7daaa3a707e1a4a542c13c891d4018d1ad6 /Makefile
parentef433a6baa3449f5a5ec7a6fd09efdd0ea6fb57b (diff)
Pass LDFLAGS instead of CFLAGS in the linking stage
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 92679b4..e1e954d 100644
--- a/Makefile
+++ b/Makefile
@@ -4,6 +4,7 @@
include config.mk
+REQ = util
HDR = arg.h
BIN = png2ff ff2png jpg2ff ff2jpg ff2pam ff2ppm
SCR = 2ff
@@ -13,7 +14,7 @@ MAN5 = farbfeld.5
all: $(BIN)
.o: $(REQ:=.o)
- $(CC) $(CFLAGS) $($*-LDFLAGS) -o $@ $< $(REQ:=.o)
+ $(CC) $(LDFLAGS) $($*-LDFLAGS) -o $@ $< $(REQ:=.o)
$(BIN:=.o): config.mk $(HDR) $(REQ:=.h)