summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorFRIGN <dev@frign.de>2016-05-18 10:33:41 +0200
committerFRIGN <dev@frign.de>2016-05-18 10:33:41 +0200
commit3d0f4c70385c8ad1dbaad1bb266e644c7109aa6a (patch)
tree86957f580956d931654b73d5e41fb1d12235ca8a /Makefile
parent545c500d4278c50e781c9a5a550e92cb0023c8e8 (diff)
Revert "Fix Makefile to rebuild when there have been changes"
This reverts commit 545c500d4278c50e781c9a5a550e92cb0023c8e8.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 80724a3..21b82d9 100644
--- a/Makefile
+++ b/Makefile
@@ -11,12 +11,10 @@ MAN5 = farbfeld.5
all: ${BIN}
-png2ff: png2ff.c
-ff2png: ff2png.c
+png2ff ff2png:
${CC} -o $@ ${CFLAGS} ${CPPFLAGS} -L${PNGLIB} -lpng -I${PNGINC} ${LDFLAGS} $@.c
-jpg2ff: jpg2ff.c
-ff2jpg: ff2jpg.c
+jpg2ff ff2jpg:
${CC} -o $@ ${CFLAGS} ${CPPFLAGS} -L${JPGLIB} -ljpeg -I${JPGINC} ${LDFLAGS} $@.c
.c: