summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorFRIGN <dev@frign.de>2016-05-17 21:53:38 +0200
committerFRIGN <dev@frign.de>2016-05-17 21:53:38 +0200
commit545c500d4278c50e781c9a5a550e92cb0023c8e8 (patch)
treec7ecbb9d69bef9ce243d8e9394dc3ddfc85b912f /Makefile
parent96faf20b1bcef354e6b1fd03a26c286070c52e74 (diff)
Fix Makefile to rebuild when there have been changes
I forgot to add the dependencies in the build process
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 21b82d9..80724a3 100644
--- a/Makefile
+++ b/Makefile
@@ -11,10 +11,12 @@ MAN5 = farbfeld.5
all: ${BIN}
-png2ff ff2png:
+png2ff: png2ff.c
+ff2png: ff2png.c
${CC} -o $@ ${CFLAGS} ${CPPFLAGS} -L${PNGLIB} -lpng -I${PNGINC} ${LDFLAGS} $@.c
-jpg2ff ff2jpg:
+jpg2ff: jpg2ff.c
+ff2jpg: ff2jpg.c
${CC} -o $@ ${CFLAGS} ${CPPFLAGS} -L${JPGLIB} -ljpeg -I${JPGINC} ${LDFLAGS} $@.c
.c: