summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorFRIGN <dev@frign.de>2015-02-03 12:56:54 +0100
committerFRIGN <dev@frign.de>2015-02-03 12:56:54 +0100
commit787ebb0e40e5e89ce9d5d56dfdf7065a63b4abe5 (patch)
treef89f4b66f908dc22408311345b3f4ed05b41161f /Makefile
parent1b79c92e0a0eaf2d603b93620b50e0ef0dc757ed (diff)
Add gif2if procedure to Makefile
Thanks to Henrique Lengler <henriqueleng@opmbx.org> for the patch!
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 2ee3152..a6a9dd6 100644
--- a/Makefile
+++ b/Makefile
@@ -43,14 +43,17 @@ clean:
install: all
@echo installing executable files to ${DESTDIR}${PREFIX}/bin
@mkdir -p ${DESTDIR}${PREFIX}/bin
- @cp -f png2if if2png jpg2if ${DESTDIR}${PREFIX}/bin
+ @cp -f png2if jpg2if if2png gif2if ${DESTDIR}${PREFIX}/bin
@chmod 755 ${DESTDIR}${PREFIX}/bin/png2if
@chmod 755 ${DESTDIR}${PREFIX}/bin/jpg2if
@chmod 755 ${DESTDIR}${PREFIX}/bin/if2png
+ @chmod 755 ${DESTDIR}${PREFIX}/bin/gif2if
uninstall:
@echo removing executable files from ${DESTDIR}${PREFIX}/bin
@rm -f ${DESTDIR}${PREFIX}/bin/png2if
+ @rm -f ${DESTDIR}${PREFIX}/bin/jpg2if
@rm -f ${DESTDIR}${PREFIX}/bin/if2png
+ @rm -f ${DESTDIR}${PREFIX}/bin/gif2if
.PHONY: all options clean install uninstall