summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorFRIGN <dev@frign.de>2015-11-09 23:39:29 +0100
committerFRIGN <dev@frign.de>2015-11-09 23:40:46 +0100
commitd5f6f70d351239ee37b3d864c9a94dc49d66c052 (patch)
tree47993f137fd273df86a4f24fe7fe22098c435e0a /Makefile
parent0b0fcaa7136d7de2e1bc5dc05a576f5fe5608995 (diff)
imagefile -> farbfeld
- Rename the format - Change the format specification - Drop old tools waiting to be fixed on a later date, just keep fixed png for now - Simplify other stuff This is a direct consequence of my slcon2-talk on this topic. At first I planned to have 64 bits per channel, but this is overkill.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile40
1 files changed, 14 insertions, 26 deletions
diff --git a/Makefile b/Makefile
index a6a9dd6..27561af 100644
--- a/Makefile
+++ b/Makefile
@@ -1,15 +1,15 @@
-# imagefile - tools to convert between png and if
+# imagefile - tools to convert between png and ff
# See LICENSE file for copyright and license details
include config.mk
-SRC = png2if.c if2png.c jpg2if.c gif2if.c
+SRC = png2ff.c ff2png.c
OBJ = ${SRC:.c=.o}
-all: options png2if if2png jpg2if gif2if
+all: options png2ff ff2png
options:
- @echo imagefile build options:
+ @echo farbfeld build options:
@echo "CFLAGS = ${CFLAGS}"
@echo "LDFLAGS = ${LDFLAGS}"
@echo "CC = ${CC}"
@@ -20,40 +20,28 @@ options:
${OBJ}: config.mk
-gif2if: gif2if.o
+png2ff: png2ff.o
@echo CC -o $@
- @${CC} -o $@ gif2if.o ${GIF_LIBS} ${LDFLAGS}
+ @${CC} -o $@ png2ff.o ${PNG_LIBS} ${LDFLAGS}
-jpg2if: jpg2if.o
+ff2png: ff2png.o
@echo CC -o $@
- @${CC} -o $@ jpg2if.o ${JPEG_LIBS} ${LDFLAGS}
-
-png2if: png2if.o
- @echo CC -o $@
- @${CC} -o $@ png2if.o ${PNG_LIBS} ${LDFLAGS}
-
-if2png: if2png.o
- @echo CC -o $@
- @${CC} -o $@ if2png.o ${PNG_LIBS} ${LDFLAGS}
+ @${CC} -o $@ ff2png.o ${PNG_LIBS} ${LDFLAGS}
clean:
@echo cleaning
- @rm -f png2if if2png jpg2if gif2if ${OBJ}
+ @rm -f png2ff ff2png ${OBJ}
install: all
@echo installing executable files to ${DESTDIR}${PREFIX}/bin
@mkdir -p ${DESTDIR}${PREFIX}/bin
- @cp -f png2if jpg2if if2png gif2if ${DESTDIR}${PREFIX}/bin
- @chmod 755 ${DESTDIR}${PREFIX}/bin/png2if
- @chmod 755 ${DESTDIR}${PREFIX}/bin/jpg2if
- @chmod 755 ${DESTDIR}${PREFIX}/bin/if2png
- @chmod 755 ${DESTDIR}${PREFIX}/bin/gif2if
+ @cp -f png2ff ff2png ${DESTDIR}${PREFIX}/bin
+ @chmod 755 ${DESTDIR}${PREFIX}/bin/png2ff
+ @chmod 755 ${DESTDIR}${PREFIX}/bin/ff2png
uninstall:
@echo removing executable files from ${DESTDIR}${PREFIX}/bin
- @rm -f ${DESTDIR}${PREFIX}/bin/png2if
- @rm -f ${DESTDIR}${PREFIX}/bin/jpg2if
- @rm -f ${DESTDIR}${PREFIX}/bin/if2png
- @rm -f ${DESTDIR}${PREFIX}/bin/gif2if
+ @rm -f ${DESTDIR}${PREFIX}/bin/png2ff
+ @rm -f ${DESTDIR}${PREFIX}/bin/ff2png
.PHONY: all options clean install uninstall