summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorFRIGN <dev@frign.de>2014-07-20 11:07:26 +0200
committerFRIGN <dev@frign.de>2014-07-20 11:07:26 +0200
commit1b6461daf115790ed5895227f5a020610835f889 (patch)
tree470ee96222e113c2435ac12615bed3e655cf326e /Makefile
parent3d16669c9f40046a09da59711b3f12d3daddeea4 (diff)
Use if-extension and naming for imagefile
Respectively, image.png will become an image.if
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile26
1 files changed, 13 insertions, 13 deletions
diff --git a/Makefile b/Makefile
index de4f4bd..be04259 100644
--- a/Makefile
+++ b/Makefile
@@ -1,12 +1,12 @@
-# imagefile - tools to convert to imagefile and back
+# imagefile - tools to convert between png and if
# See LICENSE file for copyright and license details
include config.mk
-SRC = png2imagefile.c imagefile2png.c
+SRC = png2if.c if2png.c
OBJ = ${SRC:.c=.o}
-all: options png2imagefile imagefile2png
+all: options png2if if2png
options:
@echo imagefile build options:
@@ -20,28 +20,28 @@ options:
${OBJ}: config.mk
-png2imagefile: png2imagefile.o
+png2if: png2if.o
@echo CC -o $@
- @${CC} -o $@ png2imagefile.o ${LDFLAGS}
+ @${CC} -o $@ png2if.o ${LDFLAGS}
-imagefile2png: imagefile2png.o
+if2png: if2png.o
@echo CC -o $@
- @${CC} -o $@ imagefile2png.o ${LDFLAGS}
+ @${CC} -o $@ if2png.o ${LDFLAGS}
clean:
@echo cleaning
- @rm -f png2imagefile imagefile2png ${OBJ}
+ @rm -f png2if if2png ${OBJ}
install: all
@echo installing executable files to ${DESTDIR}${PREFIX}/bin
@mkdir -p ${DESTDIR}${PREFIX}/bin
- @cp -f png2imagefile imagefile2png ${DESTDIR}${PREFIX}/bin
- @chmod 755 ${DESTDIR}${PREFIX}/bin/png2imagefile
- @chmod 755 ${DESTDIR}${PREFIX}/bin/imagefile2png
+ @cp -f png2if if2png ${DESTDIR}${PREFIX}/bin
+ @chmod 755 ${DESTDIR}${PREFIX}/bin/png2if
+ @chmod 755 ${DESTDIR}${PREFIX}/bin/if2png
uninstall:
@echo removing executable files from ${DESTDIR}${PREFIX}/bin
- @rm -f ${DESTDIR}${PREFIX}/bin/png2imagefile
- @rm -f ${DESTDIR}${PREFIX}/bin/imagefile2png
+ @rm -f ${DESTDIR}${PREFIX}/bin/png2if
+ @rm -f ${DESTDIR}${PREFIX}/bin/if2png
.PHONY: all options clean install uninstall