summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorFRIGN <dev@frign.de>2015-11-23 00:11:17 +0100
committerFRIGN <dev@frign.de>2015-11-23 00:11:17 +0100
commit2c4b975c421456bf14c2891a753da09b4a50cb0a (patch)
treea1215f6527b33a2874ea38ccbaab5451a88dd3a1 /Makefile
parenta593273a24500f14c66e5ca0c2a9948db22f36a7 (diff)
(Re)add jpg2ff
Thanks z3bra for porting this! Also change 2ff to use case instead of if-blocks.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index 966bf3f..f54f7b4 100644
--- a/Makefile
+++ b/Makefile
@@ -1,23 +1,23 @@
-# farbfeld - tools to convert between png and ff
+# farbfeld - tools to convert between png/jpg and ff
# See LICENSE file for copyright and license details
include config.mk
-SRC = png2ff.c ff2png.c
+SRC = png2ff.c ff2png.c jpg2ff.c
-all: png2ff ff2png
+all: png2ff ff2png jpg2ff
.c:
@echo CC $<
@${CC} -o $@ ${CFLAGS} ${LIBS} ${LDFLAGS} $<
clean:
- rm -f png2ff ff2png
+ rm -f png2ff ff2png jpg2ff
install:
@echo installing into ${DESTDIR}${PREFIX}/bin
@mkdir -p ${DESTDIR}${PREFIX}/bin
- @cp -f png2ff ff2png 2ff ${DESTDIR}${PREFIX}/bin
+ @cp -f jpg2ff png2ff ff2png 2ff ${DESTDIR}${PREFIX}/bin
uninstall:
@echo removing from ${DESTDIR}${PREFIX}/bin