summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorHiltjo Posthuma <hiltjo@codemadness.org>2016-03-21 21:06:06 +0100
committerFRIGN <dev@frign.de>2016-03-21 21:37:13 +0100
commitdc512d040c7d081ed96b1919420aebd646968879 (patch)
tree6f848b71c8ca8a6a0653e6ad3aeb5bc65c978621 /Makefile
parente637aae67ededf6a4a0b4d490d02f3294f297b71 (diff)
add ff2ppm(1)
ff2ppm can convert farbfeld images to PPM (P6 binary format, 24-bit RGB). ff2ppm has an option -b to set the background color, for example for png files: png2ff < test.png | ff2ppm -b '#00ff00' > test.ppm
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 236351f..63b4d0a 100644
--- a/Makefile
+++ b/Makefile
@@ -2,12 +2,13 @@
# See LICENSE file for copyright and license details
include config.mk
-BIN = png2ff ff2png jpg2ff
+BIN = png2ff ff2png jpg2ff ff2ppm
SRC = ${BIN:=.c}
+HDR = arg.h
MAN1 = 2ff.1 ${BIN:=.1}
MAN5 = farbfeld.5
-all: png2ff ff2png jpg2ff
+all: png2ff ff2png jpg2ff ff2ppm
.c:
@echo CC $<
@@ -21,7 +22,7 @@ dist: clean
@echo creating dist tarball
@mkdir -p farbfeld-${VERSION}
@cp -R FORMAT LICENSE Makefile README TODO config.mk \
- 2ff ${SRC} ${MAN1} ${MAN5} farbfeld-${VERSION}
+ 2ff ${HDR} ${SRC} ${MAN1} ${MAN5} farbfeld-${VERSION}
@tar -cf farbfeld-${VERSION}.tar farbfeld-${VERSION}
@gzip farbfeld-${VERSION}.tar
@rm -rf farbfeld-${VERSION}