summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorFRIGN <dev@frign.de>2015-11-10 00:10:21 +0100
committerFRIGN <dev@frign.de>2015-11-10 00:10:21 +0100
commit526f2c5533807c64c80811a98778be739c19872c (patch)
treebeb6aa2f2a5e6787a6e9c973d4e1382ab276dfbb /Makefile
parentd5f6f70d351239ee37b3d864c9a94dc49d66c052 (diff)
Overhaul buildsystem
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile36
1 files changed, 8 insertions, 28 deletions
diff --git a/Makefile b/Makefile
index 27561af..b8e68f7 100644
--- a/Makefile
+++ b/Makefile
@@ -4,44 +4,24 @@
include config.mk
SRC = png2ff.c ff2png.c
-OBJ = ${SRC:.c=.o}
-all: options png2ff ff2png
+all: png2ff ff2png
-options:
- @echo farbfeld build options:
- @echo "CFLAGS = ${CFLAGS}"
- @echo "LDFLAGS = ${LDFLAGS}"
- @echo "CC = ${CC}"
-
-.c.o:
+.c:
@echo CC $<
- @${CC} -c -o $@ ${CFLAGS} $<
-
-${OBJ}: config.mk
-
-png2ff: png2ff.o
- @echo CC -o $@
- @${CC} -o $@ png2ff.o ${PNG_LIBS} ${LDFLAGS}
-
-ff2png: ff2png.o
- @echo CC -o $@
- @${CC} -o $@ ff2png.o ${PNG_LIBS} ${LDFLAGS}
+ @${CC} -o $@ ${CFLAGS} ${LIBS} ${LDFLAGS} $<
clean:
- @echo cleaning
- @rm -f png2ff ff2png ${OBJ}
+ rm -f png2ff ff2png
-install: all
- @echo installing executable files to ${DESTDIR}${PREFIX}/bin
+install:
+ @echo installing into ${DESTDIR}${PREFIX}/bin
@mkdir -p ${DESTDIR}${PREFIX}/bin
@cp -f png2ff ff2png ${DESTDIR}${PREFIX}/bin
- @chmod 755 ${DESTDIR}${PREFIX}/bin/png2ff
- @chmod 755 ${DESTDIR}${PREFIX}/bin/ff2png
uninstall:
- @echo removing executable files from ${DESTDIR}${PREFIX}/bin
+ @echo removing from ${DESTDIR}${PREFIX}/bin
@rm -f ${DESTDIR}${PREFIX}/bin/png2ff
@rm -f ${DESTDIR}${PREFIX}/bin/ff2png
-.PHONY: all options clean install uninstall
+.PHONY: all clean install uninstall