summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorFRIGN <dev@frign.de>2016-01-06 18:36:58 +0100
committerFRIGN <dev@frign.de>2016-01-06 18:36:58 +0100
commitadd6f5c09238ff797dede77eea1ce30ec85bdc13 (patch)
treeaf9194d3c43feb5c74a77b75aa7d3df43d5df9ff /Makefile
parent5bc3650669e4c12105b944058b0f9cdeb186e2e5 (diff)
Bump version to 1
And add a makerule to create a tarball via make dist.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 789f817..5ce4f06 100644
--- a/Makefile
+++ b/Makefile
@@ -1,3 +1,4 @@
+# farbfeld - suckless image format with conversion tools
# See LICENSE file for copyright and license details
include config.mk
@@ -13,7 +14,17 @@ all: png2ff ff2png jpg2ff
@${CC} -o $@ ${CFLAGS} ${LIBS} ${LDFLAGS} $<
clean:
- rm -f ${BIN}
+ @echo cleaning
+ @rm -f ${BIN}
+
+dist: clean
+ @echo creating dist tarball
+ @mkdir -p farbfeld-${VERSION}
+ @cp -R FORMAT LICENSE Makefile README TODO config.mk \
+ 2ff ${SRC} ${MAN1} ${MAN5} farbfeld-${VERSION}
+ @tar -cf farbfeld-${VERSION}.tar farbfeld-${VERSION}
+ @gzip farbfeld-${VERSION}.tar
+ @rm -rf farbfeld-${VERSION}
install: all
@echo installing into ${DESTDIR}${PREFIX}/bin