summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorLaslo Hunhold <dev@frign.de>2017-04-02 20:53:55 +0200
committerLaslo Hunhold <dev@frign.de>2017-04-02 20:55:49 +0200
commitcef01ad97b1e215b0879c369e42e31bb3e5188a1 (patch)
tree9b745efa576c8e9cae246158c068734781e2b6e6 /Makefile
parentd25f3c73afa5beb83121c9b033bc0146c755ca3a (diff)
Remove prerequisite from single-suffix inference rule
This is against the standard: "The application shall ensure that the makefile does not specify prerequisites for inference rules;"[0] We are still fine though as we explicitly state the dependency on the requisite-objects in the $(BIN)-target. Thanks Lucas for pointing this out! [0]:http://pubs.opengroup.org/onlinepubs/9699919799/utilities/make.html
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 1f7446f..4752fb6 100644
--- a/Makefile
+++ b/Makefile
@@ -17,7 +17,7 @@ $(BIN): $(REQ:=.o)
$(BIN:=.o): config.mk $(HDR) $(REQ:=.h)
-.o: $(REQ:=.o)
+.o:
$(CC) $(LDFLAGS) $($*-LDFLAGS) -o $@ $< $(REQ:=.o)
clean: