summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorLaslo Hunhold <dev@frign.de>2017-03-30 09:29:06 +0200
committerLaslo Hunhold <dev@frign.de>2017-03-30 09:29:06 +0200
commitd0ce307972fbc95073666e92043fc7012ffbefdf (patch)
tree05cbd1e1a2b4f8942e1355f6f7ce10c8c6a1e2d5 /Makefile
parent0aaa36464a4ad965a3d747cc6df16137c7b5d6c5 (diff)
Mark explicit dependency on requisites for BIN
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index e1e954d..1f7446f 100644
--- a/Makefile
+++ b/Makefile
@@ -13,11 +13,13 @@ MAN5 = farbfeld.5
all: $(BIN)
-.o: $(REQ:=.o)
- $(CC) $(LDFLAGS) $($*-LDFLAGS) -o $@ $< $(REQ:=.o)
+$(BIN): $(REQ:=.o)
$(BIN:=.o): config.mk $(HDR) $(REQ:=.h)
+.o: $(REQ:=.o)
+ $(CC) $(LDFLAGS) $($*-LDFLAGS) -o $@ $< $(REQ:=.o)
+
clean:
rm -f $(BIN) $(BIN:=.o) $(REQ:=.o)