summaryrefslogtreecommitdiff
path: root/config.mk
diff options
context:
space:
mode:
authorHiltjo Posthuma <hiltjo@codemadness.org>2015-07-31 14:24:24 +0200
committerHiltjo Posthuma <hiltjo@codemadness.org>2015-07-31 14:24:24 +0200
commit0b0fcaa7136d7de2e1bc5dc05a576f5fe5608995 (patch)
treeba54644cf5c6cf4d50fa1fba63e959c8dcba7deb /config.mk
parent787ebb0e40e5e89ce9d5d56dfdf7065a63b4abe5 (diff)
config.mk: use c99, not -c90+ansi, unrecognized on OpenBSD
Diffstat (limited to 'config.mk')
-rw-r--r--config.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/config.mk b/config.mk
index f63d40c..ceae069 100644
--- a/config.mk
+++ b/config.mk
@@ -13,10 +13,10 @@ GIF_LIBS = -lgif
CPPFLAGS =
# debug
-#CFLAGS = -std=c90 -ansi -pedantic -Wall -Wextra -O0 -g -ggdb ${CPPFLAGS}
+#CFLAGS = -std=c99 -pedantic -Wall -Wextra -O0 -g -ggdb ${CPPFLAGS}
#LDFLAGS = ${LIBS}
# optimized
-CFLAGS = -std=c90 -ansi -pedantic -Wall -Wextra -Os ${CPPFLAGS}
+CFLAGS = -std=c99 -pedantic -Wall -Wextra -Os ${CPPFLAGS}
LDFLAGS = -s ${LIBS}
# compiler and linker