summaryrefslogtreecommitdiff
path: root/config.mk
diff options
context:
space:
mode:
authorParide Legovini <pl@ninthfloor.org>2017-07-16 17:36:46 +0200
committerParide Legovini <pl@ninthfloor.org>2017-07-16 17:36:46 +0200
commit31cb65d7cc6d257bcc725ef39ffbced7b465f0cc (patch)
tree28d325b462a84b8a16bd2e9aa546df75dcd1b664 /config.mk
parented0e5905eff7383b05b87ecf1689a6938f9d79d3 (diff)
parent00dd0ab39f634729ec5d99b8057b9cef6fa0f23e (diff)
Merge tag '3'
Diffstat (limited to 'config.mk')
-rw-r--r--config.mk31
1 files changed, 5 insertions, 26 deletions
diff --git a/config.mk b/config.mk
index 80228d1..b69a346 100644
--- a/config.mk
+++ b/config.mk
@@ -1,5 +1,5 @@
# farbfeld version
-VERSION = 2
+VERSION = 3
# Customize below to fit your system
@@ -7,33 +7,12 @@ VERSION = 2
PREFIX = /usr
MANPREFIX = ${PREFIX}/share/man
-PNGLIB = /usr/local/lib
-PNGINC = /usr/local/include
-
-JPGLIB = /usr/local/lib
-JPGINC = /usr/local/include
-
-INCS =
-LIBS =
-
# flags
CPPFLAGS += -D_DEFAULT_SOURCE
-CFLAGS += -std=c99 -pedantic -Wall -Os ${INCS}
-LDFLAGS += -s ${LIBS}
+CFLAGS += -std=c99 -pedantic -Wall -Wextra -Os
+LDFLAGS += -s
+PNG-LDFLAGS = -lpng
+JPG-LDFLAGS = -ljpeg
# compiler and linker
CC = cc
-
-# flags per tool.
-
-png2ff-CFLAGS := -I${PNGINC}
-png2ff-LDFLAGS := -L${PNGLIB} -lpng
-
-ff2png-CFLAGS := -I${PNGINC}
-ff2png-LDFLAGS := -L${PNGLIB} -lpng
-
-jpg2ff-CFLAGS := -I${JPGINC}
-jpg2ff-LDFLAGS := -L${JPGLIB} -ljpeg
-
-ff2jpg-CFLAGS := -I${JPGINC}
-ff2jpg-LDFLAGS := -L${JPGLIB} -ljpeg