summaryrefslogtreecommitdiff
path: root/config.mk
diff options
context:
space:
mode:
authorFRIGN <dev@frign.de>2015-11-10 00:10:21 +0100
committerFRIGN <dev@frign.de>2015-11-10 00:10:21 +0100
commit526f2c5533807c64c80811a98778be739c19872c (patch)
treebeb6aa2f2a5e6787a6e9c973d4e1382ab276dfbb /config.mk
parentd5f6f70d351239ee37b3d864c9a94dc49d66c052 (diff)
Overhaul buildsystem
Diffstat (limited to 'config.mk')
-rw-r--r--config.mk17
1 files changed, 3 insertions, 14 deletions
diff --git a/config.mk b/config.mk
index 049e12a..8e8d2d0 100644
--- a/config.mk
+++ b/config.mk
@@ -3,21 +3,10 @@
# paths
PREFIX = /usr/local
-# libs
-LIBS =
-PNG_LIBS = -lpng
-JPEG_LIBS = -ljpeg
-GIF_LIBS = -lgif
-
# flags
-CPPFLAGS =
-
-# debug
-#CFLAGS = -std=c99 -pedantic -Wall -Wextra -O0 -g -ggdb ${CPPFLAGS}
-#LDFLAGS = ${LIBS}
-# optimized
-CFLAGS = -std=c99 -pedantic -Wall -Wextra -D_DEFAULT_SOURCE -Os ${CPPFLAGS}
-LDFLAGS = -s ${LIBS}
+CPPFLAGS = -D_DEFAULT_SOURCE
+CFLAGS = -std=c99 -pedantic -Wall -Wextra -Os ${CPPFLAGS}
+LDFLAGS = -s -lpng -ljpeg -lgif
# compiler and linker
CC = cc