summaryrefslogtreecommitdiff
path: root/config.mk
diff options
context:
space:
mode:
authorLaslo Hunhold <dev@frign.de>2017-03-30 08:41:17 +0200
committerLaslo Hunhold <dev@frign.de>2017-03-30 08:43:42 +0200
commitbbe28227eb80da62fec59aa79ba7a97f5c3937b4 (patch)
tree93112dc100ab16896bd9aba53837b732b1c16a5b /config.mk
parent65829635d9f5f9f4a23c2f890c60c315bcbafee2 (diff)
Make Makefile strictly POSIX compliant
Thanks Hiltjo for the feedback! GNUisms need to be avoided like a plague, even if it means having to be a little more creative. Strict POSIX compliance means that I just worked within the bounds of the POSIX specification, hopefully without using any GNU or BSD extensions. If I did, please let me know. Tip to all Linux users: Test your Makefiles with pmake(1) instead of make(1) (= GNU make) and refer to the newest POSIX 2016 make specification[0]. [0]: http://pubs.opengroup.org/onlinepubs/9699919799/utilities/make.html
Diffstat (limited to 'config.mk')
-rw-r--r--config.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/config.mk b/config.mk
index 93988c4..d5bc6c7 100644
--- a/config.mk
+++ b/config.mk
@@ -12,8 +12,10 @@ CPPFLAGS = -D_DEFAULT_SOURCE
CFLAGS = -std=c89 -pedantic -Wall -Os
LDFLAGS = -s
-png2ff ff2png: LDFLAGS += -lpng
-jpg2ff ff2jpg: LDFLAGS += -ljpeg
+png2ff-LDFLAGS = -lpng
+ff2png-LDFLAGS = -lpng
+jpg2ff-LDFLAGS = -ljpeg
+ff2jpg-LDFLAGS = -ljpeg
# compiler and linker
CC = cc