summaryrefslogtreecommitdiff
path: root/config.mk
diff options
context:
space:
mode:
authorsin <sin@2f30.org>2014-07-29 12:18:15 +0100
committersin <sin@2f30.org>2014-07-29 12:19:25 +0100
commit6520175e32edefc42a5825518b7504f168a6b218 (patch)
tree0e6fa51d750e2fc3e3c46063e55e2beb6f8972eb /config.mk
parent6c6d1a3d4979b4919e8354cd8e656cc0cea8c7c7 (diff)
Fix type inconsistencies and remove hacky compiler options
-Os generates lots of false positives and it is not worth it much for such a small set of tools.
Diffstat (limited to 'config.mk')
-rw-r--r--config.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/config.mk b/config.mk
index b8fd603..a34fe2d 100644
--- a/config.mk
+++ b/config.mk
@@ -7,7 +7,7 @@ PREFIX = /usr/local
LIBS = -lpng
# flags
-CFLAGS = -std=c90 -pedantic -ansi -Wall -Wextra -Wno-pointer-sign -Wno-maybe-uninitialized -Wno-clobbered -Os
+CFLAGS = -std=c90 -ansi -pedantic -Wall -Wextra
LDFLAGS = -s ${LIBS}
# compiler and linker