summaryrefslogtreecommitdiff
path: root/config.mk
diff options
context:
space:
mode:
authorFRIGN <dev@frign.de>2016-01-04 23:11:25 +0100
committerFRIGN <dev@frign.de>2016-01-04 23:11:37 +0100
commit86495f8058518f7064f2ddda92314aa42163b4c0 (patch)
tree3294673c9b02a0f35cd79c510c9ca7d7449c898a /config.mk
parent7e4fe77f15ff09bce3240b9ab59fc412fdb5ccca (diff)
Update config.mk
-Wno-clobbered is not supported on OpenBSD. Let's remove it and Wextra with all its stupid warnings.
Diffstat (limited to 'config.mk')
-rw-r--r--config.mk9
1 files changed, 6 insertions, 3 deletions
diff --git a/config.mk b/config.mk
index 4c48639..6c04982 100644
--- a/config.mk
+++ b/config.mk
@@ -6,12 +6,15 @@ PREFIX = /usr/local
PNGLIB = /usr/local/lib
PNGINC = /usr/local/include
-INCS = -I${PNGINC}
-LIBS = -L${PNGLIB} -lpng -ljpeg
+JPEGLIB = /usr/local/lib
+JPEGINC = /usr/local/include
+
+INCS = -I${PNGINC} -I${JPEGINC}
+LIBS = -L${PNGLIB} -L${JPEGLIB} -lpng -ljpeg
# flags
CPPFLAGS = -D_DEFAULT_SOURCE
-CFLAGS = -std=c99 -pedantic -Wall -Wextra -Wno-clobbered -Os ${INCS} ${CPPFLAGS}
+CFLAGS = -std=c99 -pedantic -Wall -Os ${INCS} ${CPPFLAGS}
LDFLAGS = -s ${LIBS}
# compiler and linker