summaryrefslogtreecommitdiff
path: root/config.mk
diff options
context:
space:
mode:
authorFRIGN <dev@frign.de>2014-07-19 21:35:34 +0100
committerFRIGN <dev@frign.de>2014-07-19 21:35:34 +0100
commitc7507e64d03aa8fcfe225880abc37a42028a40e1 (patch)
tree5cf51ba8f0b3b0dfd4302879c899b982d7ad58cb /config.mk
Initial commit
Diffstat (limited to 'config.mk')
-rw-r--r--config.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/config.mk b/config.mk
new file mode 100644
index 0000000..7a698d9
--- /dev/null
+++ b/config.mk
@@ -0,0 +1,14 @@
+# Customize below to fit your system
+
+# paths
+PREFIX = /usr/local
+
+# libs
+LIBS = -lpng
+
+# flags
+CFLAGS = -std=c90 -pedantic -ansi -Wall -Wextra -Wno-pointer-sign -Wno-maybe-uninitialized -Os
+LDFLAGS = -s ${LIBS}
+
+# compiler and linker
+CC = cc