summaryrefslogtreecommitdiff
path: root/config.mk
diff options
context:
space:
mode:
authorHiltjo Posthuma <hiltjo@codemadness.org>2014-07-31 15:56:21 +0000
committersin <sin@2f30.org>2014-07-31 17:51:55 +0100
commit703763eb2b3f456965a4fb99793f76a3ec1fbebd (patch)
tree750dd596a73f7029a0a77d6258233789df87ce6d /config.mk
parent55f395151bedf64644b7761d8d44c47b6965609b (diff)
config.mk: add CPPFLAGS and commented debug flags
Diffstat (limited to 'config.mk')
-rw-r--r--config.mk8
1 files changed, 7 insertions, 1 deletions
diff --git a/config.mk b/config.mk
index 06616af..f63d40c 100644
--- a/config.mk
+++ b/config.mk
@@ -10,7 +10,13 @@ JPEG_LIBS = -ljpeg
GIF_LIBS = -lgif
# flags
-CFLAGS = -std=c90 -ansi -pedantic -Wall -Wextra -Os
+CPPFLAGS =
+
+# debug
+#CFLAGS = -std=c90 -ansi -pedantic -Wall -Wextra -O0 -g -ggdb ${CPPFLAGS}
+#LDFLAGS = ${LIBS}
+# optimized
+CFLAGS = -std=c90 -ansi -pedantic -Wall -Wextra -Os ${CPPFLAGS}
LDFLAGS = -s ${LIBS}
# compiler and linker